summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-25 04:04:09 +0100
committerSam James <sam@gentoo.org>2021-07-31 01:16:49 +0100
commit10413490854e9f77f765aa1b06528eab9e960de0 (patch)
tree66a4571dfb125fb91388f46c33f96bfd73c5b229 /gui-apps
parentapp-misc/khard: [QA] unconditionally install completion files (diff)
downloadgentoo-10413490854e9f77f765aa1b06528eab9e960de0.tar.gz
gentoo-10413490854e9f77f765aa1b06528eab9e960de0.tar.bz2
gentoo-10413490854e9f77f765aa1b06528eab9e960de0.zip
gui-apps/swaylock: [QA] unconditionally install completion files
QA policy [0] says that we don't conditionalise installation of small files. It's a wasteful rebuild and inconsistent across packages for when users desire completions to be available. [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swaylock/metadata.xml1
-rw-r--r--gui-apps/swaylock/swaylock-1.3-r1.ebuild (renamed from gui-apps/swaylock/swaylock-1.3.ebuild)11
-rw-r--r--gui-apps/swaylock/swaylock-1.5-r1.ebuild (renamed from gui-apps/swaylock/swaylock-1.5.ebuild)9
-rw-r--r--gui-apps/swaylock/swaylock-9999.ebuild11
4 files changed, 17 insertions, 15 deletions
diff --git a/gui-apps/swaylock/metadata.xml b/gui-apps/swaylock/metadata.xml
index f357232b5ed0..ee32d0f89da5 100644
--- a/gui-apps/swaylock/metadata.xml
+++ b/gui-apps/swaylock/metadata.xml
@@ -18,7 +18,6 @@
Swaylock is the official screen locker for <pkg>gui-wm/sway</pkg>.
</longdescription>
<use>
- <flag name="fish-completion">Enable fish completion support</flag>
<flag name="gdk-pixbuf">Enable additional image format support via the <pkg>x11-libs/gdk-pixbuf</pkg> library</flag>
</use>
<upstream>
diff --git a/gui-apps/swaylock/swaylock-1.3.ebuild b/gui-apps/swaylock/swaylock-1.3-r1.ebuild
index 3813578e21a1..5f1de9f7b816 100644
--- a/gui-apps/swaylock/swaylock-1.3.ebuild
+++ b/gui-apps/swaylock/swaylock-1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="fish-completion +gdk-pixbuf +man +pam zsh-completion"
+IUSE="+gdk-pixbuf +man +pam"
DEPEND="
dev-libs/wayland
@@ -42,13 +42,14 @@ src_configure() {
-Dman-pages=$(usex man enabled disabled)
-Dpam=$(usex pam enabled disabled)
-Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)
+
if [[ ${PV} != 9999 ]]; then
- emesonargs+=("-Dswaylock-version=${PV}")
+ emesonargs+=( "-Dswaylock-version=${PV}" )
fi
meson_src_configure
diff --git a/gui-apps/swaylock/swaylock-1.5.ebuild b/gui-apps/swaylock/swaylock-1.5-r1.ebuild
index d37597d6dedb..c3e2e1fccdce 100644
--- a/gui-apps/swaylock/swaylock-1.5.ebuild
+++ b/gui-apps/swaylock/swaylock-1.5-r1.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="fish-completion +gdk-pixbuf +man +pam zsh-completion"
+IUSE="+gdk-pixbuf +man +pam"
DEPEND="
dev-libs/wayland
@@ -39,13 +39,14 @@ src_configure() {
-Dman-pages=$(usex man enabled disabled)
-Dpam=$(usex pam enabled disabled)
-Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)
+
if [[ ${PV} != 9999 ]]; then
- emesonargs+=("-Dswaylock-version=${PV}")
+ emesonargs+=( "-Dswaylock-version=${PV}" )
fi
meson_src_configure
diff --git a/gui-apps/swaylock/swaylock-9999.ebuild b/gui-apps/swaylock/swaylock-9999.ebuild
index 1775122395b5..68f84c85db2d 100644
--- a/gui-apps/swaylock/swaylock-9999.ebuild
+++ b/gui-apps/swaylock/swaylock-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="fish-completion +gdk-pixbuf +man +pam zsh-completion"
+IUSE="+gdk-pixbuf +man +pam"
DEPEND="
dev-libs/wayland
@@ -39,13 +39,14 @@ src_configure() {
-Dman-pages=$(usex man enabled disabled)
-Dpam=$(usex pam enabled disabled)
-Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)
+
if [[ ${PV} != 9999 ]]; then
- emesonargs+=("-Dswaylock-version=${PV}")
+ emesonargs+=( "-Dswaylock-version=${PV}" )
fi
meson_src_configure