summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-01-27 13:00:45 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-01-27 13:01:35 -0600
commit19d740d97a8c910c83bdd666456c8c657e9e3f46 (patch)
tree3d7c53ecef6f2b1b93e681c9a372679bba6808d8 /gui-apps
parentwww-apps/icingaweb2: add 2.11.4 (diff)
downloadgentoo-19d740d97a8c910c83bdd666456c8c657e9e3f46.tar.gz
gentoo-19d740d97a8c910c83bdd666456c8c657e9e3f46.tar.bz2
gentoo-19d740d97a8c910c83bdd666456c8c657e9e3f46.zip
gui-apps/swaylock: add 1.7.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swaylock/Manifest1
-rw-r--r--gui-apps/swaylock/swaylock-1.7.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/gui-apps/swaylock/Manifest b/gui-apps/swaylock/Manifest
index c3e3926be5ee..462d167a3ff1 100644
--- a/gui-apps/swaylock/Manifest
+++ b/gui-apps/swaylock/Manifest
@@ -1,2 +1,3 @@
DIST swaylock-1.6.tar.gz 36439 BLAKE2B 8944bbd5ec0dd719f8dc627dbf878fcf07df3f060b56bce3ab215a2c21fe43debfeac15f6ef7eba43415f3b94a75a335fd692e653ac48407c1cf10b400f8ff67 SHA512 9a472c25e53a41c461af41af31c7fc8b275754628d0b20f4e5085cd7ca514e68361293a6e93fb6fcb7632419a3c73e4578e03294af28fe62d944cc43339f280d
+DIST swaylock-1.7.1.tar.gz 37290 BLAKE2B 2055d5b4be46926217ff596e20b4f9e46cc028f61f0283b2ce4673e828b2bf8971c5a10761c56fecbd2dd392beb522661da5981f50dfcb2ee2a7cb47429e1d30 SHA512 36cd7f92f9a936dfe1c5fe43c7722c97cbf5169c6133ac5417b1966b151bbd44d84ffffd229358d40c3c48c3ff4537fc1f81406d5563d58ed3b40050569b77f4
DIST swaylock-1.7.tar.gz 37149 BLAKE2B 7675b56a28ce932bd163cd41ce498295b61aff51d204c5323b187ddde9ea17f6ef1ac2777272fd92703e49f44b3f749645b4715a75ed54845590513e7dddd524 SHA512 44c5a4e482674caeb86da78e49d4593128a14adad2d6e46994f984b2b2b893416d6ceeb6b0b5746ad5594892e65c9dab9764bbe4bf617a90d92622a41b791ed0
diff --git a/gui-apps/swaylock/swaylock-1.7.1.ebuild b/gui-apps/swaylock/swaylock-1.7.1.ebuild
new file mode 100644
index 000000000000..aeef41c319be
--- /dev/null
+++ b/gui-apps/swaylock/swaylock-1.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Screen locker for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaylock"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+gdk-pixbuf +man +pam"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf:2 )
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.25
+ >=dev-util/wayland-scanner-1.15
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dpam=$(usex pam enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
+ "-Dbash-completions=true"
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if ! use pam; then
+ fcaps cap_sys_admin usr/bin/swaylock
+ fi
+}