summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-03-25 14:24:04 -0400
committerJoonas Niilola <juippis@gentoo.org>2023-04-05 15:30:23 +0300
commit92f76473d225a0b5b141bd2c4477a57980dd7aad (patch)
treee1e4f3ebc1ea715e23be86c29e99f243584771bc /gui-apps
parentapp-dicts/myspell-uk: add 6.1.0 (diff)
downloadgentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.tar.gz
gentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.tar.bz2
gentoo-92f76473d225a0b5b141bd2c4477a57980dd7aad.zip
gui-apps/swappy: add 1.5.1
Signed-off-by: Julien Roy <julien@jroy.ca> Closes: https://github.com/gentoo/gentoo/pull/30342 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swappy/Manifest1
-rw-r--r--gui-apps/swappy/metadata.xml13
-rw-r--r--gui-apps/swappy/swappy-1.5.1.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/gui-apps/swappy/Manifest b/gui-apps/swappy/Manifest
index 81238de5292b..a95fb25a1ec4 100644
--- a/gui-apps/swappy/Manifest
+++ b/gui-apps/swappy/Manifest
@@ -1 +1,2 @@
DIST swappy-1.4.0.tar.gz 653512 BLAKE2B d8a0e9ef6c96c3b669fe6c3592757ee5df5a616580208ad88918c3f27f227de7a553a7074fd6f039841b022897d7c2bc891e0239969403282ae1e78781462529 SHA512 5e4952ee226799c64b8890036e22e28ec169a32da1d5f9414298d5e49b98fe0237bc35b270a2320e5e8b902b7118cf3b36c495de8475d4f948159bb1626a3004
+DIST swappy-1.5.1.tar.gz 655406 BLAKE2B 8e60766db87cd8de3a0bce6064e851c2bd44387037a27afcc8a475e933ca2a34bab8c6e5c30a398a53869050cc5b8070799a1f1cabb922e6bc4035a5333180ac SHA512 688ad9006965d6a3f9d2997335bc3e8172e4f6f53551bb92603cdc1f14138c25f9f7d28a87aa1cbcefc94f5da1701443a2ddf0e883b648ecc5a0b0ca28588217
diff --git a/gui-apps/swappy/metadata.xml b/gui-apps/swappy/metadata.xml
index 83d0186e216c..21b17c6663f6 100644
--- a/gui-apps/swappy/metadata.xml
+++ b/gui-apps/swappy/metadata.xml
@@ -5,8 +5,21 @@
<email>emily@emlove.me</email>
<name>Emily Mills</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>julien@jroy.ca</email>
+ <name>Julien Roy</name>
+ </maintainer>
<maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <upstream>
+ <bugs-to>https://github.com/jtheoof/swappy/issues</bugs-to>
+ <changelog>https://github.com/jtheoof/swappy/releases</changelog>
+ <maintainer>
+ <name>Jeremy Attali</name>
+ <email>contact@jtheoof.me</email>
+ </maintainer>
+ <remote-id type="github">jtheoof/swappy</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/gui-apps/swappy/swappy-1.5.1.ebuild b/gui-apps/swappy/swappy-1.5.1.ebuild
new file mode 100644
index 000000000000..d2095c719603
--- /dev/null
+++ b/gui-apps/swappy/swappy-1.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg optfeature
+
+DESCRIPTION="A Wayland native snapshot and editor tool, inspired by Snappy on macOS"
+HOMEPAGE="https://github.com/jtheoof/swappy"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jtheoof/swappy"
+else
+ SRC_URI="https://github.com/jtheoof/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}
+ media-fonts/fontawesome[otf]
+"
+BDEPEND="
+ app-text/scdoc
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "persisting clipboard after closing" gui-apps/wl-clipboard
+}