summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-16 09:39:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-16 09:50:10 -0500
commita895723e187c34c05163d28d09659ae8dd2b44b2 (patch)
tree73a1dd13be17eb972abde1a55b03c7f735333c35 /gui-apps
parentgui-wm/sway: 1.5 bump (diff)
downloadgentoo-a895723e187c34c05163d28d09659ae8dd2b44b2.tar.gz
gentoo-a895723e187c34c05163d28d09659ae8dd2b44b2.tar.bz2
gentoo-a895723e187c34c05163d28d09659ae8dd2b44b2.zip
gui-apps/grim: 1.3.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/grim/Manifest1
-rw-r--r--gui-apps/grim/grim-1.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
index 3b6273b83c4e..c76e1bd43a97 100644
--- a/gui-apps/grim/Manifest
+++ b/gui-apps/grim/Manifest
@@ -1 +1,2 @@
DIST grim-1.2.0.tar.gz 14445 BLAKE2B e833afe5e57768e269ece0d7f99653810424449840867a37f02db4645a0dedd7829241d24a39ca00e844505ab5d2408891aac325e7f6ddd2011884fee240b44b SHA512 d58e392f00b93e031fd46a9e0175aaa5c3ce4fafb2afa3cc97ff28a9f77fc5583774f6ddf86295262749c00dd7c4e98c6041588bfa6fd70319ddfce6b903414e
+DIST grim-1.3.0.tar.gz 15103 BLAKE2B 3a0ad4370b2a074945b1412ded14b90155a0138337314a1834dc25217e2ce13b2ca5c925fd164c9363dff059def4caab036d01b5b68c21211af4ace11e558c02 SHA512 de56046375da1a0c4d787a39d97e18af964dbf40b0d18c6f99c68b4bf054cf6712ba653d69711d3bc6f50870a23649959d67c0b150ac5c637e8c9e74b0eba2e6
diff --git a/gui-apps/grim/grim-1.3.0.ebuild b/gui-apps/grim/grim-1.3.0.ebuild
new file mode 100644
index 000000000000..314e4d76d166
--- /dev/null
+++ b/gui-apps/grim/grim-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Grab images from a Wayland compositor."
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ jpeg? ( virtual/jpeg )
+ x11-libs/cairo"
+
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == 9999 ]]; then
+ BDEPEND+="man? ( ~app-text/scdoc-9999 )"
+else
+ BDEPEND+="man? ( app-text/scdoc )"
+fi
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}