summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-16 20:37:37 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-16 20:37:37 -0400
commitb834d7e86840d9f165f3ad476e83d0335c350e94 (patch)
tree3c5eee706ab9c072afb6b1507485fb4e347935b8 /gui-libs/vte-common
parentx11-libs/vte: Version bump to 0.72.1 (diff)
downloadgentoo-b834d7e86840d9f165f3ad476e83d0335c350e94.tar.gz
gentoo-b834d7e86840d9f165f3ad476e83d0335c350e94.tar.bz2
gentoo-b834d7e86840d9f165f3ad476e83d0335c350e94.zip
gui-libs/vte-common: Version bump to 0.72.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/vte-common')
-rw-r--r--gui-libs/vte-common/Manifest1
-rw-r--r--gui-libs/vte-common/vte-common-0.72.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index ffc9875f13d6..2078ab22450e 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,3 +1,4 @@
DIST vte-0.70.3.tar.bz2 502706 BLAKE2B 1fee46dee38618137781d62b27730893b0c6969cf3badfa157628621a608983be48e35ef4d8e58099c93b8be91434b257d120cab2e7a943cfecaf37ff7b3fd5d SHA512 5520bc58b0ad2f803da27985e30862de987ecc31c0137895c6945c53f99a7c16ee0281646b9e04362de934364ee7beaa1acf47dad9baf5a16ab9898d5f746d2d
DIST vte-0.70.4.tar.bz2 502950 BLAKE2B d3152c939e0b90b542aad268b455085e04c194cc6d86e4d9352b6531cf74a19bdcd16351e1f3934b1835d1470815215c19b1301136cecf43d23a6951fd8bb889 SHA512 f899c99bf5a9593fa618016a31c93e249bcc01b8635e1b878ab236de71a24a5b3cf1a032bea96855e43d894d004b0e00f20cc2e08079e52d8e7cb709cc73a7af
DIST vte-0.72.0.tar.bz2 503848 BLAKE2B 4c87f5648b17a269072a7fbe520e9cf086325d8740050b9868fd6e0d812ed78e240a3d3dc882729435bbae30fbbbfe35c0e92f36cd62e6aa8e581350b81a3f90 SHA512 198ea27d0991d825cc993746422e89b0e7b2b225e9cbdb072477dcf5b5866e79a27920233e8da63a412c5f270769e6d333470f5368d0b09b39e15d53ddbe6dd6
+DIST vte-0.72.1.tar.bz2 504271 BLAKE2B 8ab39ab8d491757ab9402ad4bfc10ca733427d2efe895204c0db580e44107a9ab005c29ce2e6934ae27e8da7c27e39d1173fe787ddb8569938a29697eed2e2e1 SHA512 a5655d2d2602183cbda1050003d7cf883e427c8e00976af4ee2685f43530d87169e31a3b9597133d14dffdc95f20f9ca1488186d8463997a2672510f5a95d145
diff --git a/gui-libs/vte-common/vte-common-0.72.1.ebuild b/gui-libs/vte-common/vte-common-0.72.1.ebuild
new file mode 100644
index 000000000000..b2ef085b763d
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.72.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/vte-${PV}"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}