summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReagan Bohan <xbjfk.github@gmail.com>2021-11-11 22:07:53 +1300
committerSam James <sam@gentoo.org>2021-11-12 01:26:33 +0000
commit429859a96de4b7c3a49ac65f72c03430db17f507 (patch)
treeb7b670e5e2898de5531876a1389af9572a8e7ceb /gui-libs
parentgames-simulation/openttd: update to 12.1 (diff)
downloadgentoo-429859a96de4b7c3a49ac65f72c03430db17f507.tar.gz
gentoo-429859a96de4b7c3a49ac65f72c03430db17f507.tar.bz2
gentoo-429859a96de4b7c3a49ac65f72c03430db17f507.zip
gui-libs/gtk-layer-shell: Bump to version 0.6.0
Closes: https://bugs.gentoo.org/765628 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Reagan Bohan <xbjfk.github@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22898 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 31d2fb0366bc..509c634bf39e 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1 +1,2 @@
DIST gtk-layer-shell-0.1.0.tar.xz 34580 BLAKE2B db815d711e53485e00de2e0b7d238f6c66ddac9ca790d5f31c44eed965ad01ee07392d27552ae21bb1eab4905cc1d5f7dad9c10fd059afb43ba85c7ea1af2aa5 SHA512 3788559405a495d43279b20b9d64e1fb0fb9be4125eb3011a623565938246310c2e81cb6d52db111e42a9cd0739bb273ccf7fcb7c52db8b74a1e44108e061c6d
+DIST gtk-layer-shell-0.6.0.tar.gz 133047 BLAKE2B cbfc5f2ae355f1308a21d09bdaf925774223179d310b752c2540666b691a0be4c45c740f79c7a02877c95bcc31293f59643938e80c38687f0f3805534af93ab4 SHA512 ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild
new file mode 100644
index 000000000000..8ea5205fb4cd
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3[introspection,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}