summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-05-18 19:57:53 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-05 21:56:32 -0400
commit5e95b1f9ac84775b95ce31f7c85b61fbdef8952c (patch)
tree40fefa36637e66765beffae7643a44c416661e37 /gui-libs
parentgui-apps/lavalauncher: new wayland application launcher (diff)
downloadgentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.tar.gz
gentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.tar.bz2
gentoo-5e95b1f9ac84775b95ce31f7c85b61fbdef8952c.zip
gui-wm/wayfire: fix dependency versioning for building
Closes: https://bugs.gentoo.org/723760 added proper dependency versions of wlroots also changed options to src_configure instead of src_compile as per standard convention not version bumping as this fixes compile bugs and no runtime changes Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/15875 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wf-config/wf-config-0.4.0.ebuild6
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/gui-libs/wf-config/wf-config-0.4.0.ebuild b/gui-libs/wf-config/wf-config-0.4.0.ebuild
index 328ec1807428..b52ae6b08e27 100644
--- a/gui-libs/wf-config/wf-config-0.4.0.ebuild
+++ b/gui-libs/wf-config/wf-config-0.4.0.ebuild
@@ -23,8 +23,8 @@ IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
- gui-libs/wlroots
media-libs/glm
+ <=gui-libs/wlroots-0.10.1
"
RDEPEND="${DEPEND}"
@@ -35,12 +35,12 @@ BDEPEND="
virtual/pkgconfig
"
-src_compile () {
+src_configure () {
local emesonargs=""
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
- meson_src_compile
+ meson_src_configure
}
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index 328ec1807428..3efe9aa8cc6b 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -23,7 +23,7 @@ IUSE="debug"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
- gui-libs/wlroots
+ ~gui-libs/wlroots-9999
media-libs/glm
"
@@ -35,12 +35,12 @@ BDEPEND="
virtual/pkgconfig
"
-src_compile () {
+src_configure () {
local emesonargs=""
if use debug; then
emesonargs+=(
"-Db_sanitize=address,undefined"
)
fi
- meson_src_compile
+ meson_src_configure
}