summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-27 21:54:04 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-27 21:58:16 -0400
commitb4d5b46bdab3a2fe537239589ac0247e997e8f2c (patch)
treecbb23447f992339301e389b99c8c302cea12476e /gui-libs
parentx11-wm/twm: Stabilize 1.0.12 ppc64, #843167 (diff)
downloadgentoo-b4d5b46bdab3a2fe537239589ac0247e997e8f2c.tar.gz
gentoo-b4d5b46bdab3a2fe537239589ac0247e997e8f2c.tar.bz2
gentoo-b4d5b46bdab3a2fe537239589ac0247e997e8f2c.zip
gui-libs/amtk: Version bump to 5.4.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/amtk/Manifest1
-rw-r--r--gui-libs/amtk/amtk-5.4.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gui-libs/amtk/Manifest b/gui-libs/amtk/Manifest
index e4650298f51a..6d8b3d2111a7 100644
--- a/gui-libs/amtk/Manifest
+++ b/gui-libs/amtk/Manifest
@@ -1,2 +1,3 @@
DIST amtk-5.2.0.tar.xz 381328 BLAKE2B b97a4b27d33bf49a97d585ecbecad04c3f2ea4e08e378d02218be5bf4aed2fe26f260ed1fd1eaa09a5b9f0e30e49901ddf860087fc630794aaa25ecda353b118 SHA512 520c9e762bdef96907320ec8dd4d3a005f262064ee402527c1087652af91c61657868189be8aedb7c0bd17758cf6d7e976da4ce941eb8a54e2d3e10ce55dc9eb
DIST amtk-5.4.0.tar.xz 57144 BLAKE2B 835ffb28ffb448cc176e0d30b4bce6ab7a03c671a2a40d21aa10e3879140886460f1917c862d071d082d123382403cfa1dfd60db436b66e62c51c4855f7478f8 SHA512 2bfa3335b881f88d3da33fe3df5e599ed315844bd1ef956d7eb1b97620099aa2cfc2b47013c4ac4721f0c08c554ea87f3811c55bd0cb0a6a8b4a8ac30a115049
+DIST amtk-5.4.1.tar.xz 58024 BLAKE2B aa65a5b8e9e4105d0ba699eef7e505ba3acb95a7014da1217b9569b68cb1ae7e7abf6debc1bd79935baa376e5a36ef197add3c3d326d97e89c7107c42ff4e582 SHA512 6257295c9c4756de622df48dd915cb591e5f3bf2d5d17dcb26f835e69c885d50e48a2634d8f7b9537638e7bdc531462670697823301ca2d257403192f6f8062c
diff --git a/gui-libs/amtk/amtk-5.4.1.ebuild b/gui-libs/amtk/amtk-5.4.1.ebuild
new file mode 100644
index 000000000000..47069d63e4d7
--- /dev/null
+++ b/gui-libs/amtk/amtk-5.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson
+
+DESCRIPTION="Actions, Menus and Toolbars Kit for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/Amtk https://gitlab.gnome.org/swilmet/amtk"
+
+LICENSE="LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection gtk-doc"
+
+RDEPEND="
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-3.22:3
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection gobject_introspection)
+ )
+ meson_src_configure
+}