summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-04-19 15:38:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-04-19 15:38:35 -0500
commitc97671878135a8c666b69cd6bb257d29c350356f (patch)
treece08b15a15a6d7e8e39f1be116d7478799179934 /gui-libs
parentgui-libs/wlroots: fix slot and live ebuild (diff)
downloadgentoo-c97671878135a8c666b69cd6bb257d29c350356f.tar.gz
gentoo-c97671878135a8c666b69cd6bb257d29c350356f.tar.bz2
gentoo-c97671878135a8c666b69cd6bb257d29c350356f.zip
gui-libs/wlroots: put the slot definition inside if statement
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/wlroots-0.13.0.ebuild3
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/gui-libs/wlroots/wlroots-0.13.0.ebuild b/gui-libs/wlroots/wlroots-0.13.0.ebuild
index f370f34a6546..da2f898bd72a 100644
--- a/gui-libs/wlroots/wlroots-0.13.0.ebuild
+++ b/gui-libs/wlroots/wlroots-0.13.0.ebuild
@@ -11,13 +11,14 @@ HOMEPAGE="https://github.com/swaywm/wlroots"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
inherit git-r3
+ SLOT="0/9999"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SLOT="0/13"
fi
LICENSE="MIT"
-SLOT="0/13"
IUSE="elogind icccm seatd systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 9cf3f67c7412..d94cab34eb83 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -11,13 +11,14 @@ HOMEPAGE="https://github.com/swaywm/wlroots"
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
inherit git-r3
+ SLOT="0/9999"
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ SLOT="0/13"
fi
LICENSE="MIT"
-SLOT="0/9999"
IUSE="x11-backend X"
DEPEND="