summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-12 22:46:57 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-12 22:46:57 -0500
commitcf2fe59269cd5db1fbec28717e9efeafe937c959 (patch)
tree0be63182ab8615b68b51892d1cd247d35a1383bb /gui-libs
parentapp-emacs/po-mode: arm64 stable (bug #697926) (diff)
downloadgentoo-cf2fe59269cd5db1fbec28717e9efeafe937c959.tar.gz
gentoo-cf2fe59269cd5db1fbec28717e9efeafe937c959.tar.bz2
gentoo-cf2fe59269cd5db1fbec28717e9efeafe937c959.zip
gui-libs/wlroots: restore 0.6.0 per user request
Closes: https://bugs.gentoo.org/693376 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.6.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 9c1e010a4b18..e40d474d3b60 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1 +1,2 @@
+DIST wlroots-0.6.0.tar.gz 497934 BLAKE2B a0b631831752e533f83ed62e402ef69b0994df050fd643cf2ef89556face4a822b3936bc758b70ab160eedda8ced16c0992dc209600914095784bba97bd26ee2 SHA512 c205d4303a381e11ef2f4db2faac1ddf9ad85c675824aae9cfe62d9f8bd313f1568d4810db1d006416783b50c8364198648a46d1ba453a0d8f659d6920618286
DIST wlroots-0.8.1.tar.gz 451814 BLAKE2B 85f221ba9068839f326e09df616f6182f518b9a129730dda794103305e3c0786d609a7cc6cb60a90c9d51cb77e3dbbc5993901271dcf1bd656c7744260561b06 SHA512 da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a
diff --git a/gui-libs/wlroots/wlroots-0.6.0.ebuild b/gui-libs/wlroots/wlroots-0.6.0.ebuild
new file mode 100644
index 000000000000..4b99b0444b45
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.6.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm64 x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind icccm rdp systemd x11-backend X"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=dev-libs/libinput-1.9.0:0=
+ >=dev-libs/wayland-1.17.0
+ media-libs/mesa[egl,gles2,gbm]
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ elogind? ( >=sys-auth/elogind-237 )
+ icccm? ( x11-libs/xcb-util-wm )
+ rdp? ( net-misc/freerdp )
+ systemd? ( >=sys-apps/systemd-237 )
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xorg-server[wayland]
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/ffmpeg:0=
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ -Dlibcap=$(usex filecaps enabled disabled)
+ -Dxcb-icccm=$(usex icccm enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
+ "-Dexamples=false"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}