summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-16 09:28:16 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-16 09:50:08 -0500
commitdb6d04b6593985feb0fe54f316d4d75fc136034a (patch)
tree5bad83576aa43b7c845807307ba98c2304483dee /gui-libs
parentdev-util/conan: update to 1.26.1 (diff)
downloadgentoo-db6d04b6593985feb0fe54f316d4d75fc136034a.tar.gz
gentoo-db6d04b6593985feb0fe54f316d4d75fc136034a.tar.bz2
gentoo-db6d04b6593985feb0fe54f316d4d75fc136034a.zip
gui-libs/wlroots: 0.11.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.11.0.ebuild76
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild4
3 files changed, 79 insertions, 2 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 913b0672eb7b..ec059680b817 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,2 +1,3 @@
DIST wlroots-0.10.0.tar.gz 454540 BLAKE2B 0d2326a62267019001be5f0d79c7b5c937ed20b952c92f0dd8cb04c3a0c06f3ef58723f552b1da1b947ea50ad91df46a543ec9705dad588db800bfa944743d11 SHA512 0e8e0c37f1afb1d99f0ecb3c2282992ffd06381aaa396c7234ead9f3ff2d5c599e766b677680ebaecf68e792054c3e42657d24f32d08bc8bcf35f9eb4bdaa876
DIST wlroots-0.10.1.tar.gz 455232 BLAKE2B 0f4def61d8501b7746ccc589d59586b3641340fb7633b0c4a7b518f1b1b5285c1ee71fb629aa0a0e649c15a4ae69b5cfbc7a034c96e545765a96ddda35f10609 SHA512 e1af5a5b6484b5f4060090e13d22d699d5aaa6926e1a6b1043d2b900f88a002ed67dacf8498f23ed3008bf8a35500f415f95b3dbcf50de5da354f309f9161d58
+DIST wlroots-0.11.0.tar.gz 481126 BLAKE2B d2262298f24948293643b02c823851b4643289f776bc087d7b67240f4c9c76a7aca03c7dc7e13a65b3d0d3a7c8a5f5246a0e282d2cb3b88bbae0ef94b906f18a SHA512 a8a0c498d10664ff0a5aab8ad1a4fd034179542eff38b058e1da7e4653c42136e4a3586634f3d0a25a985aa7f4c5d17260117d9f4a70a7f8060494c04456f575
diff --git a/gui-libs/wlroots/wlroots-0.11.0.ebuild b/gui-libs/wlroots/wlroots-0.11.0.ebuild
new file mode 100644
index 000000000000..6496ad0a75a2
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.11.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://github.com/swaywm/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/9999"
+IUSE="elogind icccm systemd x11-backend X"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ >=dev-libs/libinput-1.9.0:0=
+ >=dev-libs/wayland-1.18.0
+ >=dev-libs/wayland-protocols-1.17.0
+ media-libs/mesa[egl,gles2,gbm]
+ virtual/libudev
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ elogind? ( >=sys-auth/elogind-237 )
+ icccm? ( x11-libs/xcb-util-wm )
+ systemd? ( >=sys-apps/systemd-237 )
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xorg-server[wayland]
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.17
+ >=dev-util/meson-0.54.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ -Dxcb-icccm=$(usex icccm enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dx11-backend=$(usex x11-backend enabled disabled)
+ "-Dexamples=false"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index 35d3047c671d..6496ad0a75a2 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -23,7 +23,8 @@ REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
>=dev-libs/libinput-1.9.0:0=
- >=dev-libs/wayland-1.17.0
+ >=dev-libs/wayland-1.18.0
+ >=dev-libs/wayland-protocols-1.17.0
media-libs/mesa[egl,gles2,gbm]
virtual/libudev
x11-libs/libdrm
@@ -52,7 +53,6 @@ src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
"-Dxcb-errors=disabled"
- -Dlibcap=$(usex filecaps enabled disabled)
-Dxcb-icccm=$(usex icccm enabled disabled)
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)