summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-24 22:24:39 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-24 22:24:39 -0600
commitdd4aec11a447420af39486b1076f3e67eec06051 (patch)
tree8add5b48b331f771ab1954888c7d8f79d01c496f /gui-libs
parentmedia-libs/shaderc: Stabilize 2021.3 x86, #829937 (diff)
downloadgentoo-dd4aec11a447420af39486b1076f3e67eec06051.tar.gz
gentoo-dd4aec11a447420af39486b1076f3e67eec06051.tar.bz2
gentoo-dd4aec11a447420af39486b1076f3e67eec06051.zip
gui-libs/wlroots: 0.15.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.15.0.ebuild73
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild6
3 files changed, 77 insertions, 3 deletions
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index cf82c80ca68a..a5eb3396cd01 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -1,2 +1,3 @@
DIST wlroots-0.14.0.tar.gz 505461 BLAKE2B d2fa28f64014ef9d840838cb5938af23f6f6b211b62dc352d0d5bb824ccaa7d7a85531e1eca14feeb06d31d59955ff9a913e40a73cad21ed1ebfe76ada39d558 SHA512 83f001133cb4b11a72bb9532b7321655428826662848f67de8e3220a33d9dff4d37c859602bdc319929949d387d014a257b0347039a6649944d7b084c76bb611
DIST wlroots-0.14.1.tar.gz 505840 BLAKE2B fca4d259cdde62da0c196344ce1d0f5dd679d012ff33e3ceb5385b9374667e16d91059a2ba6a318153e79ac2f0a6464e3066e614a13398f8c433f442560d84d2 SHA512 4f557c827f9673eccf208a3644954de80e7355b95cc374cc5e851a47087b227f196e0936c0913d21a6c776c29b74de2d028a100931264e41934c747568d8ebe0
+DIST wlroots-0.15.0.tar.gz 565059 BLAKE2B d98529b4548e3b751a505a26af143be585ed42fb9617bc67b4a10747bb494f1359d7bdb75d1730a72396e7c550fe481e858a5ac88621d61671698439e3656920 SHA512 730b1e0cf003dabae23101664c6d1993636bd3a8ecbdb3c165eef415a92811c4d5228f48e0275f75361d8528f118dfb8a2298cfb05dbf6364539224ceedca447
diff --git a/gui-libs/wlroots/wlroots-0.15.0.ebuild b/gui-libs/wlroots/wlroots-0.15.0.ebuild
new file mode 100644
index 000000000000..395649f12eb2
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.15.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ SLOT="0/14"
+fi
+
+LICENSE="MIT"
+IUSE="vulkan x11-backend X"
+
+DEPEND="
+ >=dev-libs/libinput-1.14.0:0=
+ >=dev-libs/wayland-1.20.0
+ >=dev-libs/wayland-protocols-1.24
+ media-libs/mesa[egl(+),gles2,gbm(+)]
+ sys-auth/seatd:=
+ virtual/libudev
+ vulkan? (
+ dev-util/glslang:0=
+ dev-util/vulkan-headers:0=
+ media-libs/vulkan-loader:0=
+ )
+ >=x11-libs/libdrm-2.4.109:0=
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-backend? ( x11-libs/libxcb:0= )
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.24
+ >=dev-util/meson-0.60.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
+ local emesonargs=(
+ "-Dxcb-errors=disabled"
+ "-Dexamples=false"
+ "-Dwerror=false"
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ -Dxwayland=$(usex X enabled disabled)
+ -Dbackends=drm,libinput$(usex x11-backend ',x11' '')
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index df7d512ad5c5..395649f12eb2 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
SLOT="0/9999"
else
- SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
SLOT="0/14"
fi
@@ -23,7 +23,7 @@ IUSE="vulkan x11-backend X"
DEPEND="
>=dev-libs/libinput-1.14.0:0=
- >=dev-libs/wayland-1.19.0
+ >=dev-libs/wayland-1.20.0
>=dev-libs/wayland-protocols-1.24
media-libs/mesa[egl(+),gles2,gbm(+)]
sys-auth/seatd:=
@@ -33,7 +33,7 @@ DEPEND="
dev-util/vulkan-headers:0=
media-libs/vulkan-loader:0=
)
- x11-libs/libdrm
+ >=x11-libs/libdrm-2.4.109:0=
x11-libs/libxkbcommon
x11-libs/pixman
x11-backend? ( x11-libs/libxcb:0= )