summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-22 09:31:16 +0000
committerSam James <sam@gentoo.org>2021-11-22 09:31:16 +0000
commite8760e71afdded29cc222777d0a2b81b8496fe4a (patch)
treef49bc0f3e3bbc2f5cb2e70333787b105a937884f /gui-libs
parentgui-libs/xdg-desktop-portal-wlr: restore dropped keywords (diff)
downloadgentoo-e8760e71afdded29cc222777d0a2b81b8496fe4a.tar.gz
gentoo-e8760e71afdded29cc222777d0a2b81b8496fe4a.tar.bz2
gentoo-e8760e71afdded29cc222777d0a2b81b8496fe4a.zip
gui-libs/xdg-desktop-portal-wlr: fix typo; sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.5.0.ebuild4
-rw-r--r--gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild22
2 files changed, 17 insertions, 9 deletions
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.5.0.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.5.0.ebuild
index 429dff91055c..f0ce88fcabfe 100644
--- a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.5.0.ebuild
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-0.5.0.ebuild
@@ -45,9 +45,9 @@ src_configure() {
"-Dwerror=false"
)
if use systemd; then
- emesonargs+=(-Dsd-bus-provider=systemd)
+ emesonargs+=(-Dsd-bus-provider=libsystemd)
elif use elogind; then
- emesonargs+=(-Dsd-bus-provider=elogind)
+ emesonargs+=(-Dsd-bus-provider=libelogind)
else
emesonargs+=(-Dsd-bus-provider=basu)
fi
diff --git a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
index 20c8e55c9735..f0ce88fcabfe 100644
--- a/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
+++ b/gui-libs/xdg-desktop-portal-wlr/xdg-desktop-portal-wlr-9999.ebuild
@@ -22,20 +22,21 @@ IUSE="elogind systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
- >=media-video/pipewire-0.3.2:=
+ >=media-video/pipewire-0.3.34:=
+ dev-libs/inih
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14:=
- elogind? ( >=sys-auth/elogind-237 )
- systemd? ( >=sys-apps/systemd-237 )
+ || (
+ systemd? ( >=sys-apps/systemd-237 )
+ elogind? ( >=sys-auth/elogind-237 )
+ sys-libs/basu
+ )
"
RDEPEND="
${DEPEND}
sys-apps/xdg-desktop-portal
"
BDEPEND="
- >=media-video/pipewire-0.3.2:=
- >=dev-libs/wayland-protocols-1.14
- dev-libs/inih:0
+ dev-libs/wayland-protocols
virtual/pkgconfig
"
@@ -43,5 +44,12 @@ src_configure() {
local emesonargs=(
"-Dwerror=false"
)
+ if use systemd; then
+ emesonargs+=(-Dsd-bus-provider=libsystemd)
+ elif use elogind; then
+ emesonargs+=(-Dsd-bus-provider=libelogind)
+ else
+ emesonargs+=(-Dsd-bus-provider=basu)
+ fi
meson_src_configure
}