summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2020-09-13 14:10:24 +0200
committerAaron Bauman <bman@gentoo.org>2020-11-11 12:03:12 -0500
commit6b78bcb50adbc7dd16d3a5dcdc4cb04b04877b85 (patch)
treecece07ca40c69a8649160137efbdf5b4e434ab96 /gui-wm/sway/sway-9999.ebuild
parentgui-libs/wlroots: Add support for seatd (diff)
downloadgentoo-6b78bcb50adbc7dd16d3a5dcdc4cb04b04877b85.tar.gz
gentoo-6b78bcb50adbc7dd16d3a5dcdc4cb04b04877b85.tar.bz2
gentoo-6b78bcb50adbc7dd16d3a5dcdc4cb04b04877b85.zip
gui-wm/sway: Add support for seatd
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/17521 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-wm/sway/sway-9999.ebuild')
-rw-r--r--gui-wm/sway/sway-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index 336a2ad2f6d2..12347f7a6fc4 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
+IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag seatd systemd tray wallpapers X zsh-completion"
REQUIRED_USE="?? ( elogind systemd )
tray? ( || ( elogind systemd ) )"
@@ -44,11 +44,11 @@ DEPEND="
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[elogind=,seatd=,systemd=,X=]"
else
DEPEND+="
- >=gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
- <gui-libs/wlroots-0.12.0:=[elogind=,systemd=,X=]
+ >=gui-libs/wlroots-0.11.0:=[elogind=,seatd=,systemd=,X=]
+ <gui-libs/wlroots-0.12.0:=[elogind=,seatd=,systemd=,X=]
"
fi
RDEPEND="
@@ -99,14 +99,14 @@ src_configure() {
}
pkg_preinst() {
- if ! use systemd && ! use elogind; then
+ if ! use systemd && ! use elogind && ! use seatd; then
fowners root:0 /usr/bin/sway
fperms 4511 /usr/bin/sway
fi
}
pkg_postinst() {
- if ! use systemd && ! use elogind; then
+ if ! use systemd && ! use elogind && ! use seatd; then
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
elog "exec ck-launch-session sway"