summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-19 08:00:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-19 16:26:17 -0400
commit31f1c5a908248358ae1955f2b706828180198ae9 (patch)
tree9891933eaa191c9863efe71e2dd23a41857318a9 /gui-wm
parentgui-wm/hikari: define X in metadata.xml for clarity (diff)
downloadgentoo-31f1c5a908248358ae1955f2b706828180198ae9.tar.gz
gentoo-31f1c5a908248358ae1955f2b706828180198ae9.tar.bz2
gentoo-31f1c5a908248358ae1955f2b706828180198ae9.zip
gui-wm/hikari: add 2.3.2
Non-maintainer bump to support newer wlroots wrt bug #789447, with some ebuild changes: * Revert to running bmake directly. This isn't just about -lN (many more options are missing and existing ones can even mean different things), `bmake -j$(makeopts_jobs)` is more solid. Seems better to think of it as its own thing than a $MAKE drop-in replacement (like jamfiles or so). Note: MAKEFLAGS is recognized by bmake to pass extra arguments * Drop most [X?] as interest here is only wlroots xwayland support * IUSE=X now non-default to match wlroots' and use profile settings * Drop other IUSE and enable by default (trivial and no dependencies) * Pin to wlroots:0/14 to avoid future issues * Pass ETC_PREFIX at build time so it knows where to find the config * Drop upstreamed pkgconfig patch Closes: https://bugs.gentoo.org/779112 Closes: https://bugs.gentoo.org/789447 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hikari/Manifest1
-rw-r--r--gui-wm/hikari/hikari-2.3.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/gui-wm/hikari/Manifest b/gui-wm/hikari/Manifest
index aea906983002..f4f656fc45fd 100644
--- a/gui-wm/hikari/Manifest
+++ b/gui-wm/hikari/Manifest
@@ -1 +1,2 @@
DIST hikari-2.2.2.tar.gz 1019277 BLAKE2B 3cf76f0849cbc80493b6f078ec32b2a6f8e47f12ff3a015132e662dc2382f4071661126bf111550e5ab31eee69c54adaf10ec6ef64b681d7859771a180d30652 SHA512 53b1cb8b8e5fdbabcdcb5ba8af31f1cc66e89c8e94d217b7d1f89f0c733fb7969a251ef5090296b7aeca064aafc60d12878f3f2dbffa17e1fb24609e5549b4f1
+DIST hikari-2.3.2.tar.gz 1022093 BLAKE2B 8e4df4377728cc1feab3509588a9f2d5138af6e3175682672eedce4ca45d5bb9b7e56568a860871b319b3ff1213468f38f0b6253927f6ab4b905dd495c05c53e SHA512 b7485be089064dd19c4614f60066b3f7b2f322328fa771d4383db27656695746fb00ab534cc754929141c23b7556992391529e537e0522080177068f3d0e2954
diff --git a/gui-wm/hikari/hikari-2.3.2.ebuild b/gui-wm/hikari/hikari-2.3.2.ebuild
new file mode 100644
index 000000000000..119bd1fe8f0c
--- /dev/null
+++ b/gui-wm/hikari/hikari-2.3.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multiprocessing toolchain-funcs
+
+DESCRIPTION="Wayland compositor inspired by CWM"
+HOMEPAGE="https://hikari.acmelabs.space/"
+SRC_URI="https://hikari.acmelabs.space/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X suid"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libinput:=
+ dev-libs/libucl
+ dev-libs/wayland
+ gui-libs/wlroots:0/14[X?]
+ sys-libs/pam
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-misc/xkeyboard-config"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/wayland-protocols"
+BDEPEND="
+ dev-util/wayland-scanner
+ sys-devel/bmake
+ virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+
+ local bmake=(
+ bmake -j$(makeopts_jobs)
+ ETC_PREFIX="${EPREFIX}"
+ CFLAGS_EXTRA="${CFLAGS} ${CPPFLAGS}"
+ LDFLAGS_EXTRA="${LDFLAGS}"
+ VERSION=${PV}
+ -DWITH_GAMMACONTROL
+ -DWITH_LAYERSHELL
+ -DWITH_POSIX_C_SOURCE
+ -DWITH_SCREENCOPY
+ -DWITH_VIRTUAL_INPUT
+ $(usev X -DWITH_XWAYLAND)
+ )
+
+ # empty flags to avoid duplicates (some parts use only _EXTRA, others both)
+ echo "${bmake[*]}"
+ CFLAGS= LDFLAGS= "${bmake[@]}" || die
+}
+
+src_install() {
+ local bmake=(
+ bmake install
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ ETC_PREFIX="${EPREFIX}"
+ $(usev suid -DWITH_SUID)
+ )
+
+ echo "${bmake[*]}"
+ "${bmake[@]}" || die
+}