summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-11-11 12:20:53 -0500
committerAaron Bauman <bman@gentoo.org>2020-11-11 12:24:11 -0500
commit5a2742e4fb861e9c409c05ea332c9915eab1b053 (patch)
tree6c548c73eef74cd5feb2f1951ce5faa61cc8741a /gui-wm
parentgui-libs/wlroots: add seatd impl to 0.12.0 (diff)
downloadgentoo-5a2742e4fb861e9c409c05ea332c9915eab1b053.tar.gz
gentoo-5a2742e4fb861e9c409c05ea332c9915eab1b053.tar.bz2
gentoo-5a2742e4fb861e9c409c05ea332c9915eab1b053.zip
gui-wm/sway: backport seatd to 1.5.1
* Requires wlroots 0.12.0 which has seatd support Suggested-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/sway/sway-1.5.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/gui-wm/sway/sway-1.5.1.ebuild b/gui-wm/sway/sway-1.5.1.ebuild
index 5514c6774dcb..e47ade12c03c 100644
--- a/gui-wm/sway/sway-1.5.1.ebuild
+++ b/gui-wm/sway/sway-1.5.1.ebuild
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
+IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag seatd systemd tray wallpapers X zsh-completion"
REQUIRED_USE="?? ( elogind systemd )
tray? ( || ( elogind systemd ) )"
@@ -44,11 +44,11 @@ DEPEND="
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[elogind=,seatd=,systemd=,X=]"
else
DEPEND+="
- >=gui-libs/wlroots-0.12.0:=[elogind=,systemd=,X=]
- <gui-libs/wlroots-0.13.0:=[elogind=,systemd=,X=]
+ >=gui-libs/wlroots-0.12.0:=[elogind=,seatd=,systemd=,X=]
+ <gui-libs/wlroots-0.13.0:=[elogind=,seatd=,systemd=,X=]
"
fi
RDEPEND="
@@ -99,14 +99,14 @@ src_configure() {
}
pkg_preinst() {
- if ! use systemd && ! use elogind; then
+ if ! use systemd && ! use elogind && ! use seatd; then
fowners root:0 /usr/bin/sway
fperms 4511 /usr/bin/sway
fi
}
pkg_postinst() {
- if ! use systemd && ! use elogind; then
+ if ! use systemd && ! use elogind && ! use seatd; then
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
elog "exec ck-launch-session sway"