summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-10-28 13:53:10 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-10-31 17:58:43 +0200
commit8d4c4096f265600feda2364a311cb015d06a9f29 (patch)
tree9f052a961d73464209bd52f069141120bfbf1e2d /gui-wm
parentapp-emulation/genymotion-bin: removed old (diff)
downloadgentoo-8d4c4096f265600feda2364a311cb015d06a9f29.tar.gz
gentoo-8d4c4096f265600feda2364a311cb015d06a9f29.tar.bz2
gentoo-8d4c4096f265600feda2364a311cb015d06a9f29.zip
gui-wm/hikari: version bump to 2.2.2
should really fix the direct CC calls Closes: https://bugs.gentoo.org/745375 Closes: https://bugs.gentoo.org/745399 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hikari/Manifest1
-rw-r--r--gui-wm/hikari/hikari-2.2.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/gui-wm/hikari/Manifest b/gui-wm/hikari/Manifest
index fc829c5c34f5..02e31abef731 100644
--- a/gui-wm/hikari/Manifest
+++ b/gui-wm/hikari/Manifest
@@ -1 +1,2 @@
DIST hikari-2.2.1.tar.gz 1019168 BLAKE2B aa2ea50b665b3e5d62deba9565cab0d24694046d37dcd9aaa85d3581efbce339ea3f02630155fc731a7eb20dc7b4e4a301e5c6abfd1499ef962e6ef012184ca6 SHA512 640d4ef19cb445613e43fb3363ff00f13937ab256155129bbeba7adcd5f8aed1e4ddbcc6af13809c54ce14dc0d51933cc2763c8a990f44e49d6bfbf9daf62d80
+DIST hikari-2.2.2.tar.gz 1019277 BLAKE2B 3cf76f0849cbc80493b6f078ec32b2a6f8e47f12ff3a015132e662dc2382f4071661126bf111550e5ab31eee69c54adaf10ec6ef64b681d7859771a180d30652 SHA512 53b1cb8b8e5fdbabcdcb5ba8af31f1cc66e89c8e94d217b7d1f89f0c733fb7969a251ef5090296b7aeca064aafc60d12878f3f2dbffa17e1fb24609e5549b4f1
diff --git a/gui-wm/hikari/hikari-2.2.2.ebuild b/gui-wm/hikari/hikari-2.2.2.ebuild
new file mode 100644
index 000000000000..2d87cfd595d1
--- /dev/null
+++ b/gui-wm/hikari/hikari-2.2.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+DESCRIPTION="Wayland compositor inspired by CWM"
+HOMEPAGE="https://hikari.acmelabs.space/"
+SRC_URI="https://hikari.acmelabs.space/releases/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gamma layershell screencopy suid virtual-io +X"
+
+DEPEND="
+ dev-libs/libinput:=
+ dev-libs/libucl
+ >=gui-libs/wlroots-0.11.0[X?]
+ media-libs/libglvnd
+ x11-libs/cairo[X?,svg]
+ x11-libs/libxkbcommon[X?]
+ x11-libs/pango[X?]
+ x11-libs/pixman
+ sys-libs/pam
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-misc/xkeyboard-config
+"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ sys-devel/bmake
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.1-pkgconfig.patch )
+
+pkg_setup() {
+ export MAKE=bmake
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+
+ ${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \
+ CC="$(tc-getCC)" \
+ CFLAGS_EXTRA="${CFLAGS}" \
+ LDFLAGS_EXTRA="${LDFLAGS}" \
+ -DWITH_POSIX_C_SOURCE \
+ $(usex gamma -DWITH_GAMMACONTROL "") \
+ $(usex layershell -DWITH_LAYERSHELL "") \
+ $(usex screencopy -DWITH_SCREENCOPY "") \
+ $(usex suid -DWITH_SUID "") \
+ $(usex virtual-io -DWITH_VIRTUAL_INPUT "") \
+ $(usex X -DWITH_XWAYLAND "") \
+ all || die
+}
+
+src_install() {
+ ${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ install || die
+ doman share/man/man1/hikari.1
+}