summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 12:40:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-18 16:29:37 +0200
commit77996f0bd46af757187d387e251f25fdf21a33f8 (patch)
tree18c9cc45de05d82b4e08b5966b62d51dc802872e /kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild
parentwww-client/opera-beta: Old (diff)
downloadgentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.gz
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.tar.bz2
gentoo-77996f0bd46af757187d387e251f25fdf21a33f8.zip
kde-apps: Add KDE Applications 19.04.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild')
-rw-r--r--kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild b/kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild
new file mode 100644
index 000000000000..191204d119ad
--- /dev/null
+++ b/kde-apps/akonadi-contacts/akonadi-contacts-19.04.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Library for akonadi contact integration"
+KEYWORDS="~amd64 ~arm64 ~x86"
+LICENSE="GPL-2+"
+IUSE=""
+
+# some akonadi tests time out, that probably needs more work as it's ~700 tests
+RESTRICT+=" test"
+
+DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep prison)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kmime)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !<kde-apps/kdepim-runtime-18.03.80
+"