summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-15 12:37:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-15 17:12:47 +0200
commit14666358bcbc6116cc1ed18e1b697be67a459f2c (patch)
treec9dc36c5b750d2856590410b380791610ec41cf3 /kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild
parentmedia-gfx/imagemagick: drop old (diff)
downloadgentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.tar.gz
gentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.tar.bz2
gentoo-14666358bcbc6116cc1ed18e1b697be67a459f2c.zip
kde-apps: Add KDE Release Service 20.04.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild')
-rw-r--r--kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild b/kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild
new file mode 100644
index 000000000000..d5c003db5a21
--- /dev/null
+++ b/kde-apps/akonadi-search/akonadi-search-20.04.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.70.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Libraries and daemons to implement searching in Akonadi"
+HOMEPAGE="https://cgit.kde.org/akonadi-search.git"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[tools] )
+"
+RDEPEND="
+ >=dev-libs/xapian-1.3:=[chert(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ test? ( >=kde-apps/akonadi-${PVCUT}:5[mysql,postgres,sqlite] )
+"