summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 18:45:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 20:44:16 +0200
commit574a1e63fb59f2333adc047a9c3f2b929101e540 (patch)
tree370dfcc1bdb5ae3dc6a6233f2717d396155ac9f0 /kde-apps/ark
parentnet-dns/dnsdist: initscript fix (diff)
downloadgentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.gz
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.bz2
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.zip
kde-apps: Add KDE Applications 19.04.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-19.04.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 2ae2703d8586..6ed5bfefa770 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-18.12.3.tar.xz 2580024 BLAKE2B a705da9af77ff8fdebbdb2fa3a58fa2a33ccba8a297b6def20ee855b8c5f05ecc90a4f14dc29aae632f8f9dfcb996ea01660ddfd49edce942e042a89b8d51dc1 SHA512 0dc232b004134c048bb516aa43e478545b4052fba9321a6166a3bb4e05638288802f578cea51340c8416257f10e1bcbd55740a8945ae5f95cee6864f107d633f
DIST ark-19.04.0.tar.xz 2582636 BLAKE2B 2a1d035faf8c1bcfcddb27442e9b245a95a2866b51678cd7489239f0bf4821d3bcf2f4a9228891006db5b4b21080b37f62d19fd55227717bd4ac19241d58fd05 SHA512 7bcc2a98706644fc0a30bd04f40becea240c245f8fd8af941f893f4a1fe11c8e8f5ce6a9303f8172fed30db953110ce7cb7c4e50132f0392cd92ae9d02390bb5
+DIST ark-19.04.1.tar.xz 2578928 BLAKE2B bd7161b02577bf551d46bb23cf8661845392df7d92adb29e6e42dd58dd39631803238427b29a4f3d09044512770d8efc6fc6c94f402ec82b32b974c5cced22d9 SHA512 6a053239dfa0cfc0b96aad087d0912114a96a1de3f77ac8b720477c775a088d0df78531372f105cd982c9f7009d1fdeec03a06ada743142f2d2eddbe38f652de
diff --git a/kde-apps/ark/ark-19.04.1.ebuild b/kde-apps/ark/ark-19.04.1.ebuild
new file mode 100644
index 000000000000..bba063801ed4
--- /dev/null
+++ b/kde-apps/ark/ark-19.04.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="bzip2 lzma zip"
+
+BDEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version app-arch/rar; then
+ elog "For creating/extracting rar archives, installing app-arch/rar is required."
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+ fi
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+ fi
+}