summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 00:11:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-07 13:59:58 +0100
commit7f45ce7728de31bb839db16ab19319f026ab0add (patch)
tree460a42bf534d6aa491db847a52a3026e3758c161 /kde-apps/ark
parentkde-apps/gwenview: Backport exiv2-0.27 support to 18.08.3 (diff)
downloadgentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.gz
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.tar.bz2
gentoo-7f45ce7728de31bb839db16ab19319f026ab0add.zip
kde-apps: Add KDE Applications 18.12.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.12.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 3d602b385904..662db589e5eb 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-18.08.3.tar.xz 2580200 BLAKE2B 7ecfcc542d25c0a6ba8639e4a5cd353358d5188077ca309c6fe6dc07288c071083ff7a025d71d489d3fed412c63d69f33d480084afbd015b6c45b64cf08a3286 SHA512 56ec9a592cc0862dfe39dbef424b1fb09e8d32050448558c402b864756e00ba402e9fdec7159e3bd5b7013217f6cf1b33cdd4b0d663a11b8bfe5c4c76535f820
DIST ark-18.12.1.tar.xz 2580288 BLAKE2B 0108d56b3a140cc405688202e412e0e61c1153a16df1bd5455f53197fa6e5f6a8147115d1f26bd06524e77237bd4ed201a8d1155a559dc46440c6827bf640e62 SHA512 64fe8e3a300c1ff0d192c5366e1ba0f7916abd2cdb7df8f7953eff266d76462d95794d801e9d08053f53d0ca4a6406f6c7695a5ab1a982f3b6205c4e1fe59d28
+DIST ark-18.12.2.tar.xz 2579640 BLAKE2B 91cf41e38d1abb7e766a0d600912931e08b901888457cddfa0a8e8faa7c8de957b8a288fb4423b971b56d718cfcf77c7b54624fc69d67aa98f8a1bf0caa64aae SHA512 5c76cdc38755b7087a24a0e75a5d8d1bbc930a37ec85d701451e0dd457153b36923722f666852c51aa86ebd83b5bb8c2f439a42d98f118eccb3d95d87a424e31
diff --git a/kde-apps/ark/ark-18.12.2.ebuild b/kde-apps/ark/ark-18.12.2.ebuild
new file mode 100644
index 000000000000..5377e5902ef8
--- /dev/null
+++ b/kde-apps/ark/ark-18.12.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+BDEPEND="
+ sys-devel/gettext
+"
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version app-arch/rar; then
+ elog "For creating/extracting rar archives, installing app-arch/rar is required."
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "Alternatively, for only extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+ fi
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+ fi
+}