summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-11 17:17:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-11 18:14:22 +0100
commit85faab2e366afa6293f3c9781866f04631fc6213 (patch)
tree38279f6f2d8718267d122dfac04798f46f87232c /kde-apps/ark
parentprofiles/package.mask: remove obsolete media-radio/wspr entry (diff)
downloadgentoo-85faab2e366afa6293f3c9781866f04631fc6213.tar.gz
gentoo-85faab2e366afa6293f3c9781866f04631fc6213.tar.bz2
gentoo-85faab2e366afa6293f3c9781866f04631fc6213.zip
kde-apps: Add KDE Applications 17.12.1
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.12.1.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 456188ae092e..83f688bba263 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.08.3.tar.xz 1966132 BLAKE2B ec17cdd3d9682cbf2f533bb159fcc219c91426997120ac03fa4726123701b6e1d98686cdaa07330e541bd2a1189a920292c13932df824bb9855bc93c38c7c605 SHA512 c28eda02f561391a21723286de2b71b9d985a07edfabd510b690927ac598da7464b56ba6132bb0362a6fd7ddb35d99bcbeb8ef74b801cfbba22f6f6d91262fb8
DIST ark-17.12.0.tar.xz 1969924 BLAKE2B 98f686d81a0531f670f9a212ed685710eacf9bcf79d865b6690ce1e9401200151d52db00f96acc7cd5aa28100370c01674d7ed23d611bc4f9a27eae2c0d8ee31 SHA512 f4e95fe8fa87e285172ba9a7a51c09fc05684d7f6093dd5059fc04367718d57dc0620c00272242fdc04a0b8be9f9d8d99db56fb21067e39401d80e5576a8a6a8
+DIST ark-17.12.1.tar.xz 1970844 BLAKE2B 5f758bd3d555a75e1c50b29292bb28f637184d7b7af9de5193ab24348845135cc6486a196d16320d11b108eb3f7c83eeedf2a0afa46019a8c09b6f1ea9bb104a SHA512 445b98bc1fe6484cb5f2b6fb78a2d33e6d0d1898968fbcea43574567af3b3d8847fe674a2bdb342bf8ca96b862bb2de25b4f06e82715a3d99899d1279b8a9fca
diff --git a/kde-apps/ark/ark-17.12.1.ebuild b/kde-apps/ark/ark-17.12.1.ebuild
new file mode 100644
index 000000000000..c95527b9545e
--- /dev/null
+++ b/kde-apps/ark/ark-17.12.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}