summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:55:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-13 15:58:19 +0100
commitff68a61d7cd4786f56bed62410f9206e588e8d8e (patch)
tree69313c252a0aed267809ad3a0d7f31c5c10177a3 /kde-apps/ark
parentdev-php/pecl-yaz: amd64 stable wrt bug #667068 (diff)
downloadgentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.gz
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.tar.bz2
gentoo-ff68a61d7cd4786f56bed62410f9206e588e8d8e.zip
kde-apps: Add KDE Applications 18.12.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.12.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 58b4619935f1..2b2b61a20eff 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1 +1,2 @@
DIST ark-18.08.3.tar.xz 2580200 BLAKE2B 7ecfcc542d25c0a6ba8639e4a5cd353358d5188077ca309c6fe6dc07288c071083ff7a025d71d489d3fed412c63d69f33d480084afbd015b6c45b64cf08a3286 SHA512 56ec9a592cc0862dfe39dbef424b1fb09e8d32050448558c402b864756e00ba402e9fdec7159e3bd5b7013217f6cf1b33cdd4b0d663a11b8bfe5c4c76535f820
+DIST ark-18.12.0.tar.xz 2580244 BLAKE2B 79f1290ca4dcc40f9b34a838d4fc0165f8d7eb69ed3cf54ffd517b59df5e2df6dc2c627ff0a17db67fb34275638f9d808be512e0faafd89c814c82f154df0989 SHA512 015ae8c9fa8e955c627ff206e9d946ee9f572735f8e05a2a428a029811594eebb5f6354320060b4eca15c7e51d08bea33f8da5ddc8ac4a79fa6901f4b2b597c2
diff --git a/kde-apps/ark/ark-18.12.0.ebuild b/kde-apps/ark/ark-18.12.0.ebuild
new file mode 100644
index 000000000000..c6f3ec55fd70
--- /dev/null
+++ b/kde-apps/ark/ark-18.12.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}