summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-18 15:42:18 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-18 16:03:33 +0200
commit66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd (patch)
tree5096e0b3a3b9501276d23ccbdefa39f613d758d5 /kde-apps/cantor
parentapp-misc/tmux: Add 2.1-r1 and ship terminfo file. (diff)
downloadgentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.gz
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.tar.bz2
gentoo-66ef0203d4c540eb29b88a9ca47a71d54d5fa2dd.zip
kde-apps: Version bump KDE Applications 16.04.1
Except KDE PIM which is not ready for production yet, which is available (masked) in kde overlay. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-16.04.1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index fc4bf40dc85f..76173f11db88 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-15.12.3.tar.xz 350924 SHA256 0c67d99038cc7b2f59de6f001337267131e3d420035dd10a05b860859afe423b SHA512 0544574803085fdad61eb2a6896fa7b5b7fc8bd96ebb251f3b3c5efafcb9dc0e30cf8a8719c3bd8e77bcbf140e7798b8cce498ccb92db415e4e816dd19ecd0d8 WHIRLPOOL 62e637230e997bd65c098f9f92245e50c0c67d790d4b6138133188ddbedbc102254701626b9e7828c7ad8dc25602e39c00fd3a42429c580dd5ba9eeffd01aa00
+DIST cantor-16.04.1.tar.xz 350872 SHA256 02fa9e5d8d54d9e5307e668a693801fd197c909ede2f84c12efdf94a82942609 SHA512 17fe6108e41c7dec9de8c02873042c586b9c2596a88d0dddb08a0c7756fa8890966259c27fc9f7e05d24fc12a1d9fe931e8d6e94ebb931c9eabfd4082c0df797 WHIRLPOOL 816b51842cb2087eeab1e5a5f3da8098329cfc1434bd1622a9975d2344c1a1d3a86530f5152454ad00b42fa849bcecb50120862b168aef46f882ea25f15576f4
DIST cantor-4.14.3.tar.xz 342140 SHA256 8fc81454666aa082ab392ae796f233acfb83a46fd9064952c643d89bed4565e1 SHA512 5da20030a74ef4f3b9d59f37d07b4a893b1f9cfea43728b4aa7c0aefe219d0de554201bbbf57ab9cd3e10a97ba381171cd2a907843246c42616da2a5d6b6afa9 WHIRLPOOL e5d46da3a7081d23fbb47e51c96ae58cac32a6d90354bc335bfb1926ec6586070da64ee7b973aeebbe75d81eea5858fdceadecc667f17c49bbb3fb48ea43db58
diff --git a/kde-apps/cantor/cantor-16.04.1.ebuild b/kde-apps/cantor/cantor-16.04.1.ebuild
new file mode 100644
index 000000000000..bc2c493a0ca0
--- /dev/null
+++ b/kde-apps/cantor/cantor-16.04.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+# FIXME: PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor"
+KEYWORDS="~amd64 ~x86"
+IUSE="analitza lua postscript python qalculate +R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ lua? ( dev-lang/luajit:2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
+ sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
+ -i src/backends/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! use analitza && ! use lua && ! use python && ! use qalculate && ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'lua', 'python', 'qalculate' or 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}