summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:20:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-09 18:23:07 +0100
commit101f20b293d1a063a2a1237a3beeac631704d3e5 (patch)
tree4cc6096c25b56aa84df9d4b7a9d5826fae4d4d66 /kde-apps/dolphin-plugins-bazaar
parentsys-kernel/vanilla-kernel-bin: Bump to 4.19.94 LTS (diff)
downloadgentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.gz
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.tar.bz2
gentoo-101f20b293d1a063a2a1237a3beeac631704d3e5.zip
kde-apps: Add KDE Applications 19.12.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-bazaar')
-rw-r--r--kde-apps/dolphin-plugins-bazaar/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.12.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-bazaar/Manifest b/kde-apps/dolphin-plugins-bazaar/Manifest
index e758d5c8c708..6803fc964285 100644
--- a/kde-apps/dolphin-plugins-bazaar/Manifest
+++ b/kde-apps/dolphin-plugins-bazaar/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-19.08.3.tar.xz 192608 BLAKE2B 36ad06761a2e016d23af7fcfd206b7d5bd0e07a26f7268dfa40f8f111555c8f41545751c5255d94cab4c8855f3c5e47dacfe762ec4558abc7620f4c6dea1668c SHA512 a9155d8811eebfdaf0e76636746eca20e065d994a7c9e69672e8ebb9cdede118ce518e012e165d3ea82786ee53d46d044e63f208564d2de91b0c8d8c9daf509e
DIST dolphin-plugins-19.12.0.tar.xz 195968 BLAKE2B 10a294ea3950b14b5593f656d067cf8fbfbf680df7dc96e542f6afcd6c29c50d853fc2ab648a0ca151d342a42c3abc5dcc20dd328e2db1dd2aaf97550ae2226a SHA512 2f02cfd4f5b6596e350a77547f76cb484966393947c2c60940e6570c90121085588b2485ae1e46317b86e6d24189356f123f5243f221217942ede587a2d6400f
+DIST dolphin-plugins-19.12.1.tar.xz 194676 BLAKE2B 45710e8da5ba6f378dc3eda64f07185e67e6791f59c4ffad628d7678db802dfd9eb4be156e940adfc1e65ffe0351d360c4539c4a56f124fb32fb8603535e609b SHA512 e6bb49acaf6be738510f342700b73c0655147d06667a2b52fc4c4541297603cee66e4239d8c477d8e693c94d860824d6e7f0f9920104476ec5d5796741542b02
diff --git a/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.12.1.ebuild b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.12.1.ebuild
new file mode 100644
index 000000000000..9c254d28af01
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="bazaar"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Bazaar integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/bzr
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}