summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/dolphin-plugins-bazaar
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-bazaar')
-rw-r--r--kde-apps/dolphin-plugins-bazaar/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.08.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-bazaar/Manifest b/kde-apps/dolphin-plugins-bazaar/Manifest
index 214e1c28b667..1fbc933a948b 100644
--- a/kde-apps/dolphin-plugins-bazaar/Manifest
+++ b/kde-apps/dolphin-plugins-bazaar/Manifest
@@ -1 +1,2 @@
+DIST dolphin-plugins-19.08.3.tar.xz 192608 BLAKE2B 36ad06761a2e016d23af7fcfd206b7d5bd0e07a26f7268dfa40f8f111555c8f41545751c5255d94cab4c8855f3c5e47dacfe762ec4558abc7620f4c6dea1668c SHA512 a9155d8811eebfdaf0e76636746eca20e065d994a7c9e69672e8ebb9cdede118ce518e012e165d3ea82786ee53d46d044e63f208564d2de91b0c8d8c9daf509e
DIST dolphin-plugins-19.12.3.tar.xz 195464 BLAKE2B b60be81fcb9932f9f645bc614ab74c2e862ef70df6958242dc67de2b9cb570cc8961c2ac593ad99db636f19bec1793316dab21b9cee9a59cf2764b67234c312a SHA512 f6d1ce129095d0ae608b2da4d91f55b93bb8fe94795c09217cc87607bb50cd8dcc5a7dac21b8655f9993da56ef90fa705520c7ac928295edb5254050af9c4a1e
diff --git a/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.08.3.ebuild b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.08.3.ebuild
new file mode 100644
index 000000000000..a048febf08d1
--- /dev/null
+++ b/kde-apps/dolphin-plugins-bazaar/dolphin-plugins-bazaar-19.08.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="dolphin-plugins"
+ECM_HANDBOOK="false"
+MY_PLUGIN_NAME="bazaar"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Bazaar integration"
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="arm64"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ dev-vcs/bzr
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_bogus_dep Qt5 Network
+ ecm_punt_bogus_dep KF5 XmlGui
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}