summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:34:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-07 14:36:38 +0100
commitc1941078fbe8744f0710332dee5705d3a95a800b (patch)
tree2fbace875e510011c2845a85071b60cf371926d5 /kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild
parentapp-emulation/xen-tools: drop old (diff)
downloadgentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.gz
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.tar.bz2
gentoo-c1941078fbe8744f0710332dee5705d3a95a800b.zip
kde-apps: Add KDE Applications 18.12.3
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild
new file mode 100644
index 000000000000..a9451d744149
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-18.12.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KMNAME="dolphin-plugins"
+KDE_HANDBOOK="false"
+MY_PLUGIN_NAME="dropbox"
+inherit kde5
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep dolphin)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ kde5_src_prepare
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ kde5_src_configure
+}