summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-09 10:09:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-09 20:58:43 +0200
commit1bc1e59f86d61e7545ddd802a88697fadbdbd949 (patch)
tree4006d6bba820288bd5beb31ca552302595839334 /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/elisa: 20.08.2 version bump (diff)
downloadgentoo-1bc1e59f86d61e7545ddd802a88697fadbdbd949.tar.gz
gentoo-1bc1e59f86d61e7545ddd802a88697fadbdbd949.tar.bz2
gentoo-1bc1e59f86d61e7545ddd802a88697fadbdbd949.zip
kde-apps/dolphin-plugins-dropbox: 20.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.08.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 859f8deedabc..76ae2f964e9a 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-20.04.3.tar.xz 213888 BLAKE2B 8ad8e98a42c5a6d12bd3c03ffcc9f5923d1651bc10a74152f5561ebf59b50aafa24fe29d0ea6a7ce147d4f8732fa72c50664b7a890a6e4fe00c64298c8aa0bd4 SHA512 cab1d81deb8204e2d95ae10dc375d5cdc98958ae3dd0a969ee9ea78326229877cd314d2f37266b2ef1ebcdd876cffade6d7e5ee296028867f9c00592c8cd6eb6
DIST dolphin-plugins-20.08.1.tar.xz 228072 BLAKE2B f6d0b0945eb1d9872ef20468e7e8df308d240909eda12bda00181f088c0ede3462f5b8560416500c1f199c1587a544cb65b41b5f89b89f2d493e57d077fc5b73 SHA512 e4f0a8899fd26055a80081236e4a9e14ea5d73c011ee0bf6cc934f599d24047adf86b16ff7164edcc59e101f11ad5364d9381f6852a11d6d36571366ff135e7b
+DIST dolphin-plugins-20.08.2.tar.xz 229440 BLAKE2B 53d8c1c16a9ba5abcb3164cd4d30769506c4dfaaab148eed070185b17d00fc5583b5dbb28b163794e187da8e0d64435d904fb8ffc99e8625b8096bd96dbd94ab SHA512 c854c3a7c918c9a8be1da41d9d4f8039b9c8e38ba4782ae064ea688fed51966b9749ce009b2f96bcac0f92dbe36e5f826a45265eb29e3f2ec4740902485099d7
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.08.2.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.08.2.ebuild
new file mode 100644
index 000000000000..5f2f640acffb
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-20.08.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.72.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://kde.org/applications/system/org.kde.dolphin_plugins"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/dolphin-plugins:5
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_bogus_dep Qt5 DBus
+ ecm_punt_bogus_dep KF5 Solid
+ # delete non-${PN} translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}