summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-25 10:06:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-25 10:27:57 +0200
commit4eb3527eac4089ed249deacf2cddeecbde8561a2 (patch)
treed58283b1a697195ffa42bddb3404c821ce521837 /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/krecorder: 23.08.0 version bump (diff)
downloadgentoo-4eb3527eac4089ed249deacf2cddeecbde8561a2.tar.gz
gentoo-4eb3527eac4089ed249deacf2cddeecbde8561a2.tar.bz2
gentoo-4eb3527eac4089ed249deacf2cddeecbde8561a2.zip
kde-apps/dolphin-plugins-dropbox: 23.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-23.08.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 53a35785d07a..09e4ebe4aa75 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8
+DIST dolphin-plugins-23.08.0.tar.xz 273412 BLAKE2B edd20bb433b5288cc5687009cfd65d978b98de6b81dbc9b8aeb598a84411f67557e72be5212844852ce4cd7ecdd9d092e003603dfe8e6b6a5a2a30d94fbb3f58 SHA512 4abf6e41c6a4755117446ac744779ca7acdf1f1380cffa5be9931fc1463073b20c3c0b26a20de86befb49541f04523aedb8114189d68413bb75317d98ee54615
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-23.08.0.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-23.08.0.ebuild
new file mode 100644
index 000000000000..398dbe310f10
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-23.08.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}