summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:21:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-08-17 20:58:09 +0200
commitc1063afea17a29bb75dbbbf0121fa5c8ad948574 (patch)
treec62ccf9ec787742c39c2afd14ac1198894802629 /kde-apps/juk/juk-17.08.0.ebuild
parentmedia-libs/libqaccessibilityclient: New package (diff)
downloadgentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.gz
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.tar.bz2
gentoo-c1063afea17a29bb75dbbbf0121fa5c8ad948574.zip
kde-apps: Add KDE Applications 17.08.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/juk/juk-17.08.0.ebuild')
-rw-r--r--kde-apps/juk/juk-17.08.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-apps/juk/juk-17.08.0.ebuild b/kde-apps/juk/juk-17.08.0.ebuild
new file mode 100644
index 000000000000..9c62f7c2c879
--- /dev/null
+++ b/kde-apps/juk/juk-17.08.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+QT3SUPPORT_REQUIRED="true"
+inherit kde4-base
+
+DESCRIPTION="Jukebox and music manager by KDE"
+HOMEPAGE="https://www.kde.org/applications/multimedia/juk/"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ media-libs/phonon[qt4]
+ >=media-libs/taglib-1.6
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # bug 410551: for disabling deprecated TunePimp support
+ local mycmakeargs=(
+ -DWITH_TunePimp=OFF
+ )
+
+ kde4-base_src_configure
+}