summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild')
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild
new file mode 100644
index 000000000000..79ee40719750
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-16.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+inherit kde5
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+LICENSE="LGPL-2.1"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_plasma_dep kde-cli-tools)
+ sys-devel/gettext
+"
+
+# bug #549444
+RESTRICT+=" test"