summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-19 02:34:50 +0100
commit69bda468b16a78ac6fcd84b1c08671bc6ea74726 (patch)
treeffa226d7d06da09349b8cb8129a85a23ce627174 /kde-apps/kaccounts-integration
parentecm.eclass: Drop KDE Applications 19.08.3 support (diff)
downloadgentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.gz
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.tar.bz2
gentoo-69bda468b16a78ac6fcd84b1c08671bc6ea74726.zip
kde-apps: Re-add KDE Applications 19.08.3 for arm64 only
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kaccounts-integration')
-rw-r--r--kde-apps/kaccounts-integration/Manifest1
-rw-r--r--kde-apps/kaccounts-integration/kaccounts-integration-19.08.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-apps/kaccounts-integration/Manifest b/kde-apps/kaccounts-integration/Manifest
index e7b67c51e387..22ed98dc77ef 100644
--- a/kde-apps/kaccounts-integration/Manifest
+++ b/kde-apps/kaccounts-integration/Manifest
@@ -1 +1,2 @@
+DIST kaccounts-integration-19.08.3.tar.xz 71924 BLAKE2B b4c6fa383c053843c0b6529d33e8bff7f4fcbbef20287c6f102f696b1ea833e35d889342668d0617fdafc63663ba3bd47ee6178dafe1b76d8e486f8e8c3e92e9 SHA512 f1e7a1c3959b6739aeba3ab8a2bce51116b1b7263951cb55931564f2628f0fbe7eaa876dff9a4b7a4c6846853360293e5949297d4faf5d6a739579bf29245fd6
DIST kaccounts-integration-19.12.3.tar.xz 65792 BLAKE2B f965bfd94b4f5a7270474f7646fae0f5477df9ed9a0e504e9214ba2334dd2ab2ae5fe71a3e6c2d1ae5213f77434ad98ff05fe867bbbce43592e4cbbf05d5c018 SHA512 3bf8850d9d81001c30bf6fb62178501bd45e6e447093fa63f32cba0b17cb83eadc518f439653c6212e80f20be7cb76a912a632a286e94b15fa8d9c2c6ad9e681
diff --git a/kde-apps/kaccounts-integration/kaccounts-integration-19.08.3.ebuild b/kde-apps/kaccounts-integration/kaccounts-integration-19.08.3.ebuild
new file mode 100644
index 000000000000..5b6bc6068b23
--- /dev/null
+++ b/kde-apps/kaccounts-integration/kaccounts-integration-19.08.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+VIRTUALDBUS_TEST="true"
+KFMIN=5.60.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Administer web accounts for the sites and services across the Plasma desktop"
+HOMEPAGE="https://community.kde.org/KTp"
+LICENSE="LGPL-2.1"
+
+SLOT="5"
+KEYWORDS="~arm arm64"
+IUSE=""
+
+BDEPEND="
+ sys-devel/gettext
+"
+COMMON_DEPEND="
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ net-libs/accounts-qt
+ >=net-libs/libaccounts-glib-1.21:=
+ net-libs/signond
+"
+DEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+"
+
+# bug #549444
+RESTRICT+=" test"