summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-12-27 13:24:25 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-12-30 03:04:31 +1100
commit0d5c6a9567e463fb1a2901e7b91accf67c041bd7 (patch)
treed8721fd6b77608f6934e169cc736f03b02e9a959 /kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild
parentmedia-gfx/digikam: Fix build w/ media-libs/lensfun-0.3.2, bug 566624 (diff)
downloadgentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.tar.gz
gentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.tar.bz2
gentoo-0d5c6a9567e463fb1a2901e7b91accf67c041bd7.zip
kde-base: pkgmove KDE PIM to kde-apps/
Diffstat (limited to 'kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild')
-rw-r--r--kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild b/kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild
new file mode 100644
index 000000000000..aaf790d643b1
--- /dev/null
+++ b/kde-apps/kaddressbook/kaddressbook-4.14.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Address Book"
+HOMEPAGE="https://www.kde.org/applications/office/kaddressbook/"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs)
+ $(add_kdeapps_dep kdepim-common-libs)
+ dev-libs/grantlee:0
+ !kde-base/contactthemeeditor
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ grantleeeditor/contactthemeeditor
+ plugins/kaddressbook/
+ plugins/ktexteditor/
+"
+KMCOMPILEONLY="
+ grantleetheme/
+ kaddressbookgrantlee/
+"
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ grantleeeditor/grantleethemeeditor/
+ libkleo/
+ pimcommon/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-apps/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-apps/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}