summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-03-20 18:15:30 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-26 00:11:58 +1100
commitb0db5d580b55bd526d8c5f47a48bc2cb0b641b1f (patch)
tree499e18b5c2706f317beb84a22b66d1a205c70567 /kde-apps/kalzium/kalzium-15.12.3-r1.ebuild
parentkde-apps/kblocks: Drop old (diff)
downloadgentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.gz
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.tar.bz2
gentoo-b0db5d580b55bd526d8c5f47a48bc2cb0b641b1f.zip
kde-apps: Move kdeedu-meta 15.12.3 from kde overlay
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-apps/kalzium/kalzium-15.12.3-r1.ebuild')
-rw-r--r--kde-apps/kalzium/kalzium-15.12.3-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/kde-apps/kalzium/kalzium-15.12.3-r1.ebuild b/kde-apps/kalzium/kalzium-15.12.3-r1.ebuild
new file mode 100644
index 000000000000..33f5630df872
--- /dev/null
+++ b/kde-apps/kalzium/kalzium-15.12.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements"
+HOMEPAGE="https://www.kde.org/applications/education/kalzium
+https://edu.kde.org/kalzium"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="editor debug solver"
+
+DEPEND="
+ editor? (
+ >=dev-cpp/eigen-2.0.3:2
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND=${DEPEND}
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}