summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kalzium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kalzium')
-rw-r--r--kde-apps/kalzium/Manifest1
-rw-r--r--kde-apps/kalzium/kalzium-4.14.3.ebuild48
-rw-r--r--kde-apps/kalzium/metadata.xml9
3 files changed, 58 insertions, 0 deletions
diff --git a/kde-apps/kalzium/Manifest b/kde-apps/kalzium/Manifest
new file mode 100644
index 000000000000..ca92e9d8a15a
--- /dev/null
+++ b/kde-apps/kalzium/Manifest
@@ -0,0 +1 @@
+DIST kalzium-4.14.3.tar.xz 3944960 SHA256 4b8d086c942874c56b4835079991f2d86289d163d2dbb3e86390270c758317e5 SHA512 11f6f06379571cb92a7cb0c13d068596b2cbe014a5974dce628ac138c20f50ca5c207c4b6328c0c4d83dadf75d43455ce6794564933f2520dc1589570ddada94 WHIRLPOOL 50d392d8aac63dcc7143db1b2dd3e7e7c411f6457d4005b5313a0043bf68178f12c20b60e278697687aca28720b2759522c2f135dd1143873149bb4c3a754234
diff --git a/kde-apps/kalzium/kalzium-4.14.3.ebuild b/kde-apps/kalzium/kalzium-4.14.3.ebuild
new file mode 100644
index 000000000000..edda366716b5
--- /dev/null
+++ b/kde-apps/kalzium/kalzium-4.14.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements"
+HOMEPAGE="http://www.kde.org/applications/education/kalzium
+http://edu.kde.org/kalzium"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+DEPEND="
+ $(add_kdeapps_dep libkdeedu)
+ editor? (
+ >=dev-cpp/eigen-2.0.3:2
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND=${DEPEND}
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ local mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-apps/kalzium/metadata.xml b/kde-apps/kalzium/metadata.xml
new file mode 100644
index 000000000000..0400e2eb5dfa
--- /dev/null
+++ b/kde-apps/kalzium/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="editor">Enable the embedded molecule editor/viewer</flag>
+ <flag name="solver">Enable the equation solver</flag>
+ </use>
+ <herd>kde</herd>
+</pkgmetadata>