summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-01 19:39:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-01 20:20:32 +0100
commitbeb6ed08d4fbd0d732510a629faf8faeefb49f01 (patch)
tree8f7bb6fd6e020f566dfed6ca4ac76c56b1b22b78 /kde-apps/kblog
parentkde-plasma: Drop KDE Plasma 5.13.5 (diff)
downloadgentoo-beb6ed08d4fbd0d732510a629faf8faeefb49f01.tar.gz
gentoo-beb6ed08d4fbd0d732510a629faf8faeefb49f01.tar.bz2
gentoo-beb6ed08d4fbd0d732510a629faf8faeefb49f01.zip
kde-apps: Drop KDE Applications 18.04.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kblog')
-rw-r--r--kde-apps/kblog/Manifest1
-rw-r--r--kde-apps/kblog/files/kblog-18.04.3-syndication.patch219
-rw-r--r--kde-apps/kblog/kblog-18.04.3-r1.ebuild26
-rw-r--r--kde-apps/kblog/kblog-18.04.3.ebuild24
4 files changed, 0 insertions, 270 deletions
diff --git a/kde-apps/kblog/Manifest b/kde-apps/kblog/Manifest
index cd0d866562d1..59d6d2f528c8 100644
--- a/kde-apps/kblog/Manifest
+++ b/kde-apps/kblog/Manifest
@@ -1,2 +1 @@
-DIST kblog-18.04.3.tar.xz 72472 BLAKE2B e4460ad17033afba4be89f29348d5849d98455f4ab479f626cc59b44243932017ed546b0a3851e4615bb892ab33660018d44d8eff38621b62c6ee66fa36fd136 SHA512 c12df99b010a67a3b653a6a0c79209b37b03195b94df27e2bc805ae939f572df99c29e70a182fcce5aee8c792a7b48446e1e6f032493a420896dd39c207cafae
DIST kblog-18.08.3.tar.xz 72956 BLAKE2B 0c084723c856ac09066046ee0ad456812929a15cdc57972f49dcf6b6b77a00c3c8f0f46150a0c6dec968cf8e6e50a97bdf03f3d3c47f0c0804c98aaea13651e0 SHA512 1a319774f8d76e59615276df785c3ac602eeb2c2bdae7db0d94d4a3ed5c67af19a670593ca1c4e5dbcf17a8769f1d4abf21ed609240f76d3e7b01010d73fea3c
diff --git a/kde-apps/kblog/files/kblog-18.04.3-syndication.patch b/kde-apps/kblog/files/kblog-18.04.3-syndication.patch
deleted file mode 100644
index 4771666c0f02..000000000000
--- a/kde-apps/kblog/files/kblog-18.04.3-syndication.patch
+++ /dev/null
@@ -1,219 +0,0 @@
-From 85fc601b7c622a04c383331841733d681bfc50f3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Daniel=20Vr=C3=A1til?= <dvratil@kde.org>
-Date: Sun, 22 Apr 2018 15:37:01 +0200
-Subject: Fix build against Syndication
-
----
- src/CMakeLists.txt | 1 +
- src/feedretriever.cpp | 68 +++++++++++++++++++++++++++++++++++++++++++++++++++
- src/feedretriever.h | 54 ++++++++++++++++++++++++++++++++++++++++
- src/gdata.cpp | 11 +++++----
- 4 files changed, 129 insertions(+), 5 deletions(-)
- create mode 100644 src/feedretriever.cpp
- create mode 100644 src/feedretriever.h
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 03cef4e..1742abb 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -4,6 +4,7 @@ set(kblog_SRCS
- blogcomment.cpp
- blogmedia.cpp
- blogger1.cpp
-+ feedretriever.cpp
- gdata.cpp
- # livejournal.cpp
- metaweblog.cpp
-diff --git a/src/feedretriever.cpp b/src/feedretriever.cpp
-new file mode 100644
-index 0000000..9d481c6
---- /dev/null
-+++ b/src/feedretriever.cpp
-@@ -0,0 +1,68 @@
-+/*
-+ This file is part of Akregator.
-+
-+ Copyright (C) 2018 Daniel Vrátil <dvratil@kde.org>
-+
-+ This program is free software; you can redistribute it and/or modify
-+ it under the terms of the GNU General Public License as published by
-+ the Free Software Foundation; either version 2 of the License, or
-+ (at your option) any later version.
-+
-+ This program is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ GNU General Public License for more details.
-+
-+ You should have received a copy of the GNU General Public License
-+ along with this program; if not, write to the Free Software
-+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+
-+ As a special exception, permission is given to link this program
-+ with any edition of Qt, and distribute the resulting executable,
-+ without including the source code for Qt in the source distribution.
-+*/
-+
-+#include "feedretriever.h"
-+
-+#include <KIO/StoredTransferJob>
-+
-+#include <QUrl>
-+
-+using namespace KBlog;
-+
-+FeedRetriever::FeedRetriever()
-+ : Syndication::DataRetriever()
-+{
-+}
-+
-+void FeedRetriever::retrieveData(const QUrl &url)
-+{
-+ auto job = KIO::storedGet(url, KIO::NoReload, KIO::HideProgressInfo);
-+ connect(job, &KJob::result, this, &FeedRetriever::getFinished);
-+ mJob = job;
-+ mJob->start();
-+}
-+
-+int FeedRetriever::errorCode() const
-+{
-+ return mError;
-+}
-+
-+void FeedRetriever::abort()
-+{
-+ if (mJob) {
-+ mJob->kill();
-+ mJob = nullptr;
-+ }
-+}
-+
-+void FeedRetriever::getFinished(KJob *job)
-+{
-+ if (job->error()) {
-+ mError = job->error();
-+ Q_EMIT dataRetrieved({}, false);
-+ return;
-+ }
-+
-+ Q_EMIT dataRetrieved(static_cast<KIO::StoredTransferJob*>(job)->data(), true);
-+}
-diff --git a/src/feedretriever.h b/src/feedretriever.h
-new file mode 100644
-index 0000000..fb28020
---- /dev/null
-+++ b/src/feedretriever.h
-@@ -0,0 +1,54 @@
-+/*
-+ This file is part of Akregator.
-+
-+ Copyright (C) 2018 Daniel Vrátil <dvratil@kde.org>
-+
-+ This program is free software; you can redistribute it and/or modify
-+ it under the terms of the GNU General Public License as published by
-+ the Free Software Foundation; either version 2 of the License, or
-+ (at your option) any later version.
-+
-+ This program is distributed in the hope that it will be useful,
-+ but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ GNU General Public License for more details.
-+
-+ You should have received a copy of the GNU General Public License
-+ along with this program; if not, write to the Free Software
-+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+
-+ As a special exception, permission is given to link this program
-+ with any edition of Qt, and distribute the resulting executable,
-+ without including the source code for Qt in the source distribution.
-+*/
-+
-+#ifndef FEEDRETRIEVER_H_
-+#define FEEDRETRIEVER_H_
-+
-+#include <syndication/dataretriever.h>
-+
-+class KJob;
-+
-+namespace KBlog {
-+
-+class FeedRetriever : public Syndication::DataRetriever
-+{
-+ Q_OBJECT
-+public:
-+ explicit FeedRetriever();
-+
-+ void retrieveData(const QUrl &url) override;
-+ void abort() override;
-+ int errorCode() const override;
-+
-+private Q_SLOTS:
-+ void getFinished(KJob *job);
-+
-+private:
-+ KJob *mJob = nullptr;
-+ int mError = 0;
-+};
-+
-+}
-+
-+#endif
-diff --git a/src/gdata.cpp b/src/gdata.cpp
-index 9ca5b84..115e0a0 100644
---- a/src/gdata.cpp
-+++ b/src/gdata.cpp
-@@ -23,6 +23,7 @@
- #include "gdata_p.h"
- #include "blogpost.h"
- #include "blogcomment.h"
-+#include "feedretriever.h"
-
- #include <syndication/loader.h>
- #include <syndication/item.h>
-@@ -103,7 +104,7 @@ void GData::listBlogs()
- SIGNAL(loadingComplete(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)),
- this,
- SLOT(slotListBlogs(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)));
-- loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/blogs").arg(profileId())));
-+ loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/blogs").arg(profileId())), new FeedRetriever);
- }
-
- void GData::listRecentPosts(const QStringList &labels, int number,
-@@ -145,7 +146,7 @@ void GData::listRecentPosts(const QStringList &labels, int number,
- SIGNAL(loadingComplete(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)),
- this,
- SLOT(slotListRecentPosts(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)));
-- loader->loadFrom(url);
-+ loader->loadFrom(url, new FeedRetriever);
- }
-
- void GData::listRecentPosts(int number)
-@@ -165,7 +166,7 @@ void GData::listComments(KBlog::BlogPost *post)
- this,
- SLOT(slotListComments(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)));
- loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/") + blogId() + QLatin1Char('/') +
-- post->postId() + QStringLiteral("/comments/default")));
-+ post->postId() + QStringLiteral("/comments/default")), new FeedRetriever);
- }
-
- void GData::listAllComments()
-@@ -176,7 +177,7 @@ void GData::listAllComments()
- SIGNAL(loadingComplete(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)),
- this,
- SLOT(slotListAllComments(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)));
-- loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/comments/default").arg(blogId())));
-+ loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/comments/default").arg(blogId())), new FeedRetriever);
- }
-
- void GData::fetchPost(KBlog::BlogPost *post)
-@@ -196,7 +197,7 @@ void GData::fetchPost(KBlog::BlogPost *post)
- SIGNAL(loadingComplete(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)),
- this,
- SLOT(slotFetchPost(Syndication::Loader*,Syndication::FeedPtr,Syndication::ErrorCode)));
-- loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/posts/default").arg(blogId())));
-+ loader->loadFrom(QUrl(QStringLiteral("http://www.blogger.com/feeds/%1/posts/default").arg(blogId())), new FeedRetriever);
- }
-
- void GData::modifyPost(KBlog::BlogPost *post)
---
-cgit v0.11.2
diff --git a/kde-apps/kblog/kblog-18.04.3-r1.ebuild b/kde-apps/kblog/kblog-18.04.3-r1.ebuild
deleted file mode 100644
index 9c93a45c0d09..000000000000
--- a/kde-apps/kblog/kblog-18.04.3-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Library providing client-side support for web application remote blogging APIs"
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kxmlrpcclient)
- $(add_frameworks_dep syndication)
- $(add_kdeapps_dep kcalcore)
-"
-RDEPEND="${DEPEND}
- !kde-apps/kdepim-l10n
-"
-
-PATCHES=( "${FILESDIR}/${P}-syndication.patch" )
diff --git a/kde-apps/kblog/kblog-18.04.3.ebuild b/kde-apps/kblog/kblog-18.04.3.ebuild
deleted file mode 100644
index 582ecc3b742a..000000000000
--- a/kde-apps/kblog/kblog-18.04.3.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KDE_TEST="true"
-inherit kde5
-
-DESCRIPTION="Library providing client-side support for web application remote blogging APIs"
-LICENSE="GPL-2+"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kxmlrpcclient)
- $(add_kdeapps_dep kcalcore)
- $(add_kdeapps_dep syndication)
-"
-RDEPEND="${DEPEND}
- !kde-apps/kdepim-l10n
-"