summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:53:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit44068399ad98520a66cafb092af777af8d77a11e (patch)
tree41ec18453e7fe581c9f6020280baaa81ae0a167d /kde-apps/kdepim-runtime
parentkde-frameworks: Add KDE Frameworks 5.50.0 (diff)
downloadgentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.gz
gentoo-44068399ad98520a66cafb092af777af8d77a11e.tar.bz2
gentoo-44068399ad98520a66cafb092af777af8d77a11e.zip
kde-apps: Add KDE Applications 18.08.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-apps/kdepim-runtime')
-rw-r--r--kde-apps/kdepim-runtime/Manifest1
-rw-r--r--kde-apps/kdepim-runtime/kdepim-runtime-18.08.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/kde-apps/kdepim-runtime/Manifest b/kde-apps/kdepim-runtime/Manifest
index fe026723455a..d6823df05124 100644
--- a/kde-apps/kdepim-runtime/Manifest
+++ b/kde-apps/kdepim-runtime/Manifest
@@ -1 +1,2 @@
DIST kdepim-runtime-18.04.3.tar.xz 1750516 BLAKE2B 09bbca0580ca2a835d61ab48a004fde691b70d04b03a9da3ccf52abfad16d341e6007ef890d0fda364f679650c6d07e78c2bddd5a4b0dcfb296f24bd0e2c046a SHA512 94770f46d9a100117adf05b03ad75aa3201ae4fc2a6b300bdc3ffc42003e1a54cf8b1275d28c78f32ac764f56e58909dfbc1448b3ab8a9625485d64e8366e68e
+DIST kdepim-runtime-18.08.1.tar.xz 1749284 BLAKE2B bde5353ba5568969f8156b6aaa90decf2fb4cd531a627969652fcbfe64b62308e7ea5e39089037240946ffc5a880535712221b78e73163fda5f5d2903b714aa1 SHA512 16a6babe3a4cd0af0e7998cba9d110cf08d8cc14010b3df3053232ca8d19b584a13266e8b115eab1bec22a09363c6aeaa95e2ec0f3223aef423a6e7e5119f0aa
diff --git a/kde-apps/kdepim-runtime/kdepim-runtime-18.08.1.ebuild b/kde-apps/kdepim-runtime/kdepim-runtime-18.08.1.ebuild
new file mode 100644
index 000000000000..e0f43fe40e34
--- /dev/null
+++ b/kde-apps/kdepim-runtime/kdepim-runtime-18.08.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="speech"
+
+# TODO kolab
+CDEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kholidays)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep akonadi-mime)
+ $(add_kdeapps_dep akonadi-notes)
+ $(add_kdeapps_dep kalarmcal)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kdav)
+ $(add_kdeapps_dep kidentitymanagement)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kmailtransport)
+ $(add_kdeapps_dep kmbox)
+ $(add_kdeapps_dep kmime)
+ $(add_kdeapps_dep libkgapi)
+ $(add_kdeapps_dep pimcommon)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/cyrus-sasl:2
+ dev-libs/libical:=
+ speech? ( $(add_qt_dep qtspeech) )
+"
+DEPEND="${CDEPEND}
+ $(add_qt_dep qtxmlpatterns)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kimap 'test') )
+"
+RDEPEND="${CDEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-misc/akonadi-ews
+ $(add_frameworks_dep oxygen-icons)
+"
+
+RESTRICT+=" test"
+
+src_prepare() {
+ kde5_src_prepare
+ # We don't build kolab, so we can disable this
+ punt_bogus_dep KF5 KDELibs4Support
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package speech Qt5TextToSpeech)
+ )
+
+ kde5_src_configure
+}