summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-11-20 01:01:35 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-11-22 05:46:11 +1100
commitc15a6d88a1709f6a71dafae9a105b5c39c32db3b (patch)
tree3314216bd759eb677cefa1802626c26b9bce77c6 /kde-apps/kdesu/kdesu-15.08.3.ebuild
parentkde-apps: Drop KDE Applications 15.08.1 (diff)
downloadgentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.tar.gz
gentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.tar.bz2
gentoo-c15a6d88a1709f6a71dafae9a105b5c39c32db3b.zip
kde-apps: Bump existing ebuilds to 15.08.3 from overlay
Diffstat (limited to 'kde-apps/kdesu/kdesu-15.08.3.ebuild')
-rw-r--r--kde-apps/kdesu/kdesu-15.08.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-apps/kdesu/kdesu-15.08.3.ebuild b/kde-apps/kdesu/kdesu-15.08.3.ebuild
new file mode 100644
index 000000000000..1800359c95e4
--- /dev/null
+++ b/kde-apps/kdesu/kdesu-15.08.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+HOMEPAGE+=" https://techbase.kde.org/Projects/kdesu"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}