summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:20 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 19:18:36 +0200
commit2fb79a4076772020c18be0215abb7a430ac12b3b (patch)
tree02e6972566d0e4e18611dfd81121657a95919e66 /kde-apps/kig
parentdev-libs/libinput: Restore version 1.10.6 (diff)
downloadgentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.gz
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.tar.bz2
gentoo-2fb79a4076772020c18be0215abb7a430ac12b3b.zip
kde-apps: Add KDE Applications 18.04.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/kig-18.04.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
index 04c435b81855..35abf0ddabd5 100644
--- a/kde-apps/kig/Manifest
+++ b/kde-apps/kig/Manifest
@@ -1,2 +1,3 @@
DIST kig-17.12.3.tar.xz 3589648 BLAKE2B ebe02b35f3244d3e9f262dace700f194b8083f0f3f996c12b466ae1f722085205bc39e8a743ed201f5e41c5b201cc512c2b5700f6c2a11d3c596479c718f9b2a SHA512 bf6201c74627e3892a584c455875f6aeabf466aa092ff35255423e152ca59b9b4d364281c740ba5f65ec3b6a208628ed229368c223193c28ae0c7fa6a21aee36
DIST kig-18.04.1.tar.xz 3592016 BLAKE2B 6074d66cd8c2637d47c3099e58dc9fa679524ea0fc91eac76abee743502ccae20c1b8ffbe5706627f1e08e3e1814d4482a1bfb36b4ef6589cc5f2b84b997f12c SHA512 53a7c8d391629f387d99f47d7e710392a61d49c30395a0381927d949b70c237b1ec3cd200d5a94519ac39deac86a09354c0bd6a43c5839a1bb61eabbba604e03
+DIST kig-18.04.2.tar.xz 3592260 BLAKE2B 52e6f5a8b4331553a0bfb849207fcccd32444919019cc9ef7b03e956d43e2f9d2c765fac18d6c7eed84d48882a104dc2cf58d835ebde2663199ee5b331992876 SHA512 6de1d50baff032f46cda8440e344556176bfa356353c08ca26a632afe1e73c3fafca034cf29519d6c537c5d42f1e43f377ae114c022f209bff371599267d7d49
diff --git a/kde-apps/kig/kig-18.04.2.ebuild b/kde-apps/kig/kig-18.04.2.ebuild
new file mode 100644
index 000000000000..7e2644a1fb74
--- /dev/null
+++ b/kde-apps/kig/kig-18.04.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="https://www.kde.org/applications/education/kig https://edu.kde.org/kig"
+KEYWORDS="~amd64 ~x86"
+IUSE="geogebra scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ geogebra? ( $(add_qt_dep qtxmlpatterns) )
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep ktexteditor)
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package geogebra Qt5XmlPatterns)
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde5_src_configure
+}