summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/kig
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kig')
-rw-r--r--kde-apps/kig/Manifest1
-rw-r--r--kde-apps/kig/kig-18.12.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/kig/Manifest b/kde-apps/kig/Manifest
index d149805a469e..8586e3c0ff7a 100644
--- a/kde-apps/kig/Manifest
+++ b/kde-apps/kig/Manifest
@@ -1,2 +1,3 @@
DIST kig-18.08.3.tar.xz 3596736 BLAKE2B 68397898b47c9e0d2d7fb589612759fee7b330d76260517ac9cd2baf81f1326ae9ec52d68b5f9c7579eee817e639ec52adcb63240cc9b9aa3438d8bfbaefb1fe SHA512 c85a109e628bf129f859ff3577e1b57284a5424266769e807abcd65f3198c041a3ab11ef274fd4f45636d77be070141a496a5227e176f04b8e8a186a966049ff
DIST kig-18.12.0.tar.xz 3498592 BLAKE2B ae020ce5e1277ce36c43e9fd13810b37081d37ee220bab303cd2dcbc2e6fab9fe9a91c18595102c60c0132c5b398338d91f4e4dccbe31b2280a3f79e655ab08d SHA512 16905ab1da3f5b33df969467da5428183e29c22e2d35b9d0606ac4a170363f2f172ab45c1969100847852420ed786967c12cc3f36e29537fea2aeb9301d411c5
+DIST kig-18.12.1.tar.xz 3498588 BLAKE2B 305dc60ad932c50ae3a42b0bd1f701388d4295cce7b2020ca29a6b731f85489750da6362930d61be17d38025b48dda7defae516bac10bad9cecd26b4a9caa63f SHA512 ced987ad076c7795d967e7798662703bcb078a7382ece51cd867b9e1db9379ebef23ebebc598948cc40383469febef2c4744f0887d163937b73df407dd7bd11a
diff --git a/kde-apps/kig/kig-18.12.1.ebuild b/kde-apps/kig/kig-18.12.1.ebuild
new file mode 100644
index 000000000000..4531ee416a0b
--- /dev/null
+++ b/kde-apps/kig/kig-18.12.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde5
+
+DESCRIPTION="KDE Interactive Geometry tool"
+HOMEPAGE="https://www.kde.org/applications/education/kig https://edu.kde.org/kig/"
+KEYWORDS="~amd64 ~x86"
+IUSE="geogebra scripting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ geogebra? ( $(add_qt_dep qtxmlpatterns) )
+ scripting? ( >=dev-libs/boost-1.48:=[python,${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep ktexteditor)
+"
+
+PATCHES=( "${FILESDIR}/${PN}-4.12.0-boostpython.patch" )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+ python_fix_shebang .
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package geogebra Qt5XmlPatterns)
+ $(cmake-utils_use_find_package scripting BoostPython)
+ )
+
+ kde5_src_configure
+}