summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 18:45:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 20:44:16 +0200
commit574a1e63fb59f2333adc047a9c3f2b929101e540 (patch)
tree370dfcc1bdb5ae3dc6a6233f2717d396155ac9f0 /kde-apps/kldap/kldap-19.04.1.ebuild
parentnet-dns/dnsdist: initscript fix (diff)
downloadgentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.gz
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.tar.bz2
gentoo-574a1e63fb59f2333adc047a9c3f2b929101e540.zip
kde-apps: Add KDE Applications 19.04.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap/kldap-19.04.1.ebuild')
-rw-r--r--kde-apps/kldap/kldap-19.04.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-apps/kldap/kldap-19.04.1.ebuild b/kde-apps/kldap/kldap-19.04.1.ebuild
new file mode 100644
index 000000000000..d63a4f5e4d3d
--- /dev/null
+++ b/kde-apps/kldap/kldap-19.04.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Library for interacting with LDAP servers"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}