summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:25:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:28:13 +0100
commit0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac (patch)
tree0e4a9ab3a24db08d0f6c7b61b0d5821e99bd4497 /kde-apps/kldap
parentecm.eclass: cmake-utils_use_find_package -> cmake_use_find_package (diff)
downloadgentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.gz
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.bz2
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.zip
kde-apps: Add KDE Release Service 19.12.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-19.12.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index 588da7da4372..758ebdadff2d 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1 +1,2 @@
DIST kldap-19.08.3.tar.xz 155372 BLAKE2B df9dd8216da743db09e9e059067a91c4776e26847f1413f281708fdb04372aed7186e7a0b2d1d2bf04a5cca657cfee290c7fa14470c7d1b64244284fafb65213 SHA512 c2e21c0b3755228aea5b2612cb495565aa2161e3502b1d72b5063eb2ee15b4ea1ee820b8183b2820607bc1b0e2eaf33a6983eaa025c2224e557f10dd17fc9d37
+DIST kldap-19.12.0.tar.xz 155216 BLAKE2B be4747893cf98479c4d6efd6ca03cdc4b454c4eecec8da96aba05a63fe9841b8c466b3ec77ae0ff6580f5e0d5a500061bbec9fd723fa6d2d15a87cbb57cfcfcd SHA512 ae788a0cf42c26d5de832e50dc3083fee8f0a66a1e6a39f3713d26e037d379aab1accb351ea185bfaf3fc99b0fc366e6ae47fe8bd1534ca5bb118d6faea3c2f0
diff --git a/kde-apps/kldap/kldap-19.12.0.ebuild b/kde-apps/kldap/kldap-19.12.0.ebuild
new file mode 100644
index 000000000000..23d6f94125f7
--- /dev/null
+++ b/kde-apps/kldap/kldap-19.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with LDAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kldap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ dev-libs/cyrus-sasl
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}