summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-23 12:14:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-24 00:06:55 +0200
commit676a79636007840dd187ee278f14c416d27c03fe (patch)
treecb720563f718dd6463117035261bc709a5bc1ce0 /kde-apps/kldap
parentprofiles: use.desc: Add 'telemetry' (diff)
downloadgentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.gz
gentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.bz2
gentoo-676a79636007840dd187ee278f14c416d27c03fe.zip
kde-apps: Add KDE Release Service 20.04.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-20.04.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
index a791c2bdf3e3..582a401939a7 100644
--- a/kde-apps/kldap/Manifest
+++ b/kde-apps/kldap/Manifest
@@ -1 +1,2 @@
DIST kldap-19.12.3.tar.xz 155404 BLAKE2B 978e693f19f0ff0258d963d758d18ea865d76b552a7f6fb10afeaec409f558fbc5f459447c491f226891351cf254cb081091dbd8ee4644dd1a70013fa024af86 SHA512 5c0446d31c34d018910f50d0edc947400798a33af3a41b77989dd80f8657b13f71472aa3a2eafd5d51c703f7e72a76a6279bb9c93b1cdc4fc7dc8c676ef17435
+DIST kldap-20.04.0.tar.xz 149088 BLAKE2B b299dba1dafed1c2fd2bd567dffd9bfb46d4f035d3164b53f280d1d9d4dfac7ec10578e361db09584bb43219224c00cc4a663daa61ddf73661871c1443da6ea6 SHA512 6b9ec5391bca9f157e8da0c1521bd1c511cc02640f2503a7251bc643b907b626f353c15edf22d9213a3c04ad8d204219df1cb724d06df08d621084356f378799
diff --git a/kde-apps/kldap/kldap-20.04.0.ebuild b/kde-apps/kldap/kldap-20.04.0.ebuild
new file mode 100644
index 000000000000..54f2c333f8a2
--- /dev/null
+++ b/kde-apps/kldap/kldap-20.04.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.69.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with LDAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kldap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}