summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-12 19:24:29 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-12 19:24:41 +0100
commit2066cf7b5a1da5ded50affbdc96467b431140f3e (patch)
treeeec619c4a351b2aa2376ea6f0d543086f9b9c747 /kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild
parentdev-python/bandit: bup (diff)
downloadgentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.gz
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.tar.bz2
gentoo-2066cf7b5a1da5ded50affbdc96467b431140f3e.zip
kde-apps: Version bump KDE Applications 16.12.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild')
-rw-r--r--kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild b/kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild
new file mode 100644
index 000000000000..cc28736f1572
--- /dev/null
+++ b/kde-apps/klinkstatus/klinkstatus-16.12.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE web development - link validity checker"
+HOMEPAGE="https://www.kde.org/applications/development/klinkstatus/"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug tidy"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs)
+ tidy? ( app-text/htmltidy )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_LibTidy=$(usex tidy)
+ )
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version dev-lang/ruby ; then
+ elog "To use scripting in ${PN}, install dev-lang/ruby."
+ fi
+}