summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-08-03 22:07:50 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-08-05 00:15:51 +1000
commit8f33ed3cfcfb14094825ecd1aea658ef4957fd69 (patch)
treefb24ce8a60ea623e6ba2f39da4d40169c584d087 /kde-apps/kmix
parentnet-analyzer/mtr: Fix building with USE="-ipv6 -gtk". (diff)
downloadgentoo-8f33ed3cfcfb14094825ecd1aea658ef4957fd69.tar.gz
gentoo-8f33ed3cfcfb14094825ecd1aea658ef4957fd69.tar.bz2
gentoo-8f33ed3cfcfb14094825ecd1aea658ef4957fd69.zip
kde-apps/kmix: Fix runtime crash on volume change
Gentoo-bug: 590406 Upstream commit: 7aa904ecacfd2eeaa91068e17cc9bd79ba058206 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-apps/kmix')
-rw-r--r--kde-apps/kmix/files/kmix-16.04.3-crashfix.patch26
-rw-r--r--kde-apps/kmix/kmix-16.04.3-r1.ebuild56
2 files changed, 82 insertions, 0 deletions
diff --git a/kde-apps/kmix/files/kmix-16.04.3-crashfix.patch b/kde-apps/kmix/files/kmix-16.04.3-crashfix.patch
new file mode 100644
index 000000000000..c2ce07c52d7a
--- /dev/null
+++ b/kde-apps/kmix/files/kmix-16.04.3-crashfix.patch
@@ -0,0 +1,26 @@
+commit 7aa904ecacfd2eeaa91068e17cc9bd79ba058206
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Thu Jul 28 12:49:32 2016 +0200
+
+ Fix infinite recursion by scroll wheel volume change
+
+ BUGS: 364141
+ REVIEW: 128546
+
+diff --git a/gui/viewdockareapopup.cpp b/gui/viewdockareapopup.cpp
+index 846d9be..24e462b 100644
+--- a/gui/viewdockareapopup.cpp
++++ b/gui/viewdockareapopup.cpp
+@@ -137,9 +137,11 @@ void ViewDockAreaPopup::wheelEvent ( QWheelEvent * e )
+ {
+ if ( _mdws.isEmpty() )
+ return;
+-
++
++#ifndef X_KMIX_KF5_BUILD
+ // Pass wheel event from "border widget" to child
+ QApplication::sendEvent( _mdws.first(), e);
++#endif
+ }
+
+
diff --git a/kde-apps/kmix/kmix-16.04.3-r1.ebuild b/kde-apps/kmix/kmix-16.04.3-r1.ebuild
new file mode 100644
index 000000000000..cac642935ab4
--- /dev/null
+++ b/kde-apps/kmix/kmix-16.04.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="false"
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Plasma mixer gui"
+HOMEPAGE="https://www.kde.org/applications/multimedia/kmix/"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa pulseaudio"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ alsa? ( >=media-libs/alsa-lib-1.0.14a )
+ pulseaudio? (
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.12
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+PATCHES=( "${FILESDIR}/${P}-crashfix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DKMIX_KF5_BUILD=ON
+ $(cmake-utils_use_find_package alsa Alsa)
+ $(cmake-utils_use_find_package pulseaudio Canberra)
+ $(cmake-utils_use_find_package pulseaudio PulseAudio)
+ )
+
+ kde5_src_configure
+}