summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-02 14:44:01 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-02 14:44:14 +0200
commit8714337264d82d26e3dc1bcf5d00e86f8d1d799f (patch)
tree13a1a5fbb2894201d101f86ed158a84fa5ebe87f /kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild
parentsys-apps/man-db: Add Prefix keyword ~amd64-linux (diff)
downloadgentoo-8714337264d82d26e3dc1bcf5d00e86f8d1d799f.tar.gz
gentoo-8714337264d82d26e3dc1bcf5d00e86f8d1d799f.tar.bz2
gentoo-8714337264d82d26e3dc1bcf5d00e86f8d1d799f.zip
kde-apps: Add KDE PIM 4 maintenance snapshot
Import from kde overlay. Some improvements compared to last official release. Gentoo-bug: 560376 Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild')
-rw-r--r--kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild b/kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild
new file mode 100644
index 000000000000..0f2366fe2327
--- /dev/null
+++ b/kde-apps/knotes/knotes-4.14.11_pre20160211.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+EGIT_BRANCH="KDE/4.14"
+inherit kde4-meta
+
+DESCRIPTION="KDE Notes application"
+HOMEPAGE="https://www.kde.org/applications/utilities/knotes/"
+COMMIT_ID="2aec255c6465676404e4694405c153e485e477d9"
+SRC_URI="https://quickgit.kde.org/?p=kdepim.git&a=snapshot&h=${COMMIT_ID}&fmt=tgz -> ${KMNAME}-${PV}.tar.gz"
+
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs 'akonadi(+)')
+ $(add_kdeapps_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMCOMPILEONLY="
+ noteshared/
+"
+
+KMEXTRACTONLY="
+ akonadi_next/
+ pimcommon/
+"
+
+KMLOADLIBS="kdepim-common-libs"