summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 13:25:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-03 14:02:32 +0200
commit6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa (patch)
tree6af447d96e53bdac9f9ca597278e3d8fb4ca2340 /kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild
parentkde-apps/akonadi: Fix a regression when updating attributes (diff)
downloadgentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.tar.gz
gentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.tar.bz2
gentoo-6ab66a4b6fbdb9dae6ee14d9e1a620dcb96da8aa.zip
kde-apps: Ensure rebuild against >=kde-apps/akonadi-18.12.3-r1
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild')
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild b/kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild
new file mode 100644
index 000000000000..4899c006bb6c
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-18.12.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+KMNAME="akonadi-calendar-tools"
+inherit kde5
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_kdeapps_dep akonadi '' 18.12.3-r1)
+ $(add_kdeapps_dep akonadi-calendar)
+ $(add_kdeapps_dep calendarsupport)
+ $(add_kdeapps_dep kcalcore)
+ $(add_kdeapps_dep kcalutils)
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+ !kde-apps/konsolekalendar:4
+"
+
+src_prepare() {
+ kde5_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}