summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-23 12:14:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-24 00:06:55 +0200
commit676a79636007840dd187ee278f14c416d27c03fe (patch)
treecb720563f718dd6463117035261bc709a5bc1ce0 /kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild
parentprofiles: use.desc: Add 'telemetry' (diff)
downloadgentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.gz
gentoo-676a79636007840dd187ee278f14c416d27c03fe.tar.bz2
gentoo-676a79636007840dd187ee278f14c416d27c03fe.zip
kde-apps: Add KDE Release Service 20.04.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild')
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild b/kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild
new file mode 100644
index 000000000000..b9d5e5ba6430
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-20.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.69.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}