summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-24 12:04:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-24 15:46:28 +0200
commit41ec3bc9630fc33c39475dbe5a0d3c6baf07d095 (patch)
tree1923db62670d12d54a6343d3a5b594370bf41590 /kde-apps/konsolekalendar
parentkde-apps/knotes: 21.04.0 version bump (diff)
downloadgentoo-41ec3bc9630fc33c39475dbe5a0d3c6baf07d095.tar.gz
gentoo-41ec3bc9630fc33c39475dbe5a0d3c6baf07d095.tar.bz2
gentoo-41ec3bc9630fc33c39475dbe5a0d3c6baf07d095.zip
kde-apps/konsolekalendar: 21.04.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-21.04.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 5894174bb02a..13470065cc76 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1 +1,2 @@
DIST akonadi-calendar-tools-20.12.3.tar.xz 224860 BLAKE2B 0f03e653c6cde40a1288fe24d92d612e238768fe38f9c10e7ddf0a20c18cdc8ce44c85e416a0535bf45a8730dee33358a8027a2c7a67442e98d65066de5c3109 SHA512 5890454e49f4cfb04e3edb4895eb4f4f7abfba691185ccc9b9b3c3efc3d675cfe8c7b493b3378143d5da552ff784a391fd194c7107e4ddd11434aa3c130e5d56
+DIST akonadi-calendar-tools-21.04.0.tar.xz 228368 BLAKE2B 559106c1042eccddeea6c311faeda95088f9dffde304d59bacc1cc49cd8a0ec66e9875249c12813602e02ad09ea6dd94b350a7c056e7e5b8f769a5f7af3d9d90 SHA512 8f159cb3fc41b26bec66fc4499e19835a6935d84cb7cd9a95468b7f2fc6dc72de848b0ade88b83780946c222f8130bc90cac8de879d0cb669d5a9a060085098f
diff --git a/kde-apps/konsolekalendar/konsolekalendar-21.04.0.ebuild b/kde-apps/konsolekalendar/konsolekalendar-21.04.0.ebuild
new file mode 100644
index 000000000000..706a5c6fb40d
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-21.04.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.80.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}