summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-04-30 01:20:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-01 09:48:59 +0200
commit1565c2d62b4dd7f7e87c3063e83b472def2c8c88 (patch)
treef748a5130f1092a6fb3d45fc5f4c008edd00a527 /kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild
parentkde-apps: Add necessary blockers against incompatible kdepimlibs (diff)
downloadgentoo-1565c2d62b4dd7f7e87c3063e83b472def2c8c88.tar.gz
gentoo-1565c2d62b4dd7f7e87c3063e83b472def2c8c88.tar.bz2
gentoo-1565c2d62b4dd7f7e87c3063e83b472def2c8c88.zip
kde-apps/kdepimlibs: Fix compatibility with app-crypt/gpgme[cxx,qt5]
Avoid file collisions by renaming the affected files. Maintainer comments: - 4.14.{11_pre,10_p}20160611 are two incarnations of the same tarball 4.14.10_p20160611 reverts one commit that breaks POP3 w/ kmail-4.4 - Applied ebuild sed,mv and patch magic to sources. - Applied Gentoo patches to sources to obsolete $FILESDIR Gentoo-bug: 611818 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild')
-rw-r--r--kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild b/kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild
new file mode 100644
index 000000000000..2ff704b88d89
--- /dev/null
+++ b/kde-apps/kontact/kontact-4.14.11_pre20160611.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="Container application to unify several major PIM applications within one"
+HOMEPAGE="https://www.kde.org/applications/office/kontact/"
+
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs 'akonadi(+)')
+ $(add_kdeapps_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="kdepim-common-libs"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+KMEXTRACTONLY="
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ libkdepimdbusinterfaces/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}